Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Nvidia GTX 760

  1. #11
    Join Date
    Jan 2011
    Location
    stin paralia
    Beans
    49
    Distro
    Xubuntu 12.10 Quantal Quetzal

    Re: Nvidia GTX 760

    I never quite got to the root problem of tearing on NVidia either, but I always do this and it sorts it out. Edit /etc/X11/xorg.conf and add:

    Code:
    Section "Extensions"
      Option "Composite" "Disable"
    EndSection
    OFC that stops desktop compositing (trendy effects which I don't care too much about) but tearing is gone.

    T

  2. #12
    Join Date
    May 2008
    Location
    The Netherlands
    Beans
    2,149
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: Nvidia GTX 760

    Thanks for the tip TiberiusT, but unfortunately it did not help.
    Why is this happening? I now switched to Linuxmint 15 KDE which is a year newer than the 12.04 I used to have. Still I have this problem.
    Who has some more ideas, any help is appreciated.

    Edit:

    Some extra info:
    Nvidia driver 310.44
    kernel 3.8.0-26-generic
    Last edited by DeMus; October 13th, 2013 at 09:08 PM.
    DeMus

  3. #13
    Join Date
    Jan 2011
    Location
    stin paralia
    Beans
    49
    Distro
    Xubuntu 12.10 Quantal Quetzal

    Re: Nvidia GTX 760

    Hmmm...that works for me on XFCE. Anyway your problem is definitely 'tearing' - a well known issue. I can't offer any more solutions but I would install XBMC (in the repos), try playing thru that and if that doesn't work then post on their forums. That's where the pros are for issues like this. There's a tonne of threads about tearing there and it's nearly always a choice of 'compositing=video tearing' or 'no compositing=clean video'.

    Here's one to get yu started http://forum.xbmc.org/showthread.php...96%23pid805496

    T

  4. #14
    Join Date
    May 2008
    Location
    The Netherlands
    Beans
    2,149
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: Nvidia GTX 760

    I made some of the changes in my xorg.conf file and I did install XBMC (not my favorite though). When I open a file in XBMC I still have the tearing, when I boot into an XBMC session it is either gone or as good as gone.(bit hard to see)
    So it definitely made a change. Thing is it is a bit much to reboot every time just to watch a video and to reboot again after having seen it. Pls I have to switch off the autologin or I will boot into Mint.
    In the thread you mentioned they are talking about Ubuntu 11.04, I now use the Mint variation of Ubuntu 13.04, meaning 2 years later, several new kernels, new video-cards and drivers and this problem still exists. How is that possible?
    I will see if I can post something on an Nivida forum just to get some attention to the problem.
    Thanks TiberiusT for your help.
    Maybe you can tell me something about your setup, which card do you use, which driver, show me your xorg.conf file and maybe other files as well just to be able to compare. It is strange that the solution you mentioned worked for you and does not do it for me. Thanks.
    DeMus

  5. #15
    Join Date
    Jan 2011
    Location
    stin paralia
    Beans
    49
    Distro
    Xubuntu 12.10 Quantal Quetzal

    Re: Nvidia GTX 760

    when I boot into an XBMC session it is either gone or as good as gone
    That leads me to think that an XBMC session automatically kills compositing on startup - which would be logical. Yu shud go thru all settings to try and kill it in KDE.

    I agree . Unfo tearing has always been an issue for me and it's nowhere near to being banished yet - I watch a lot of video and the issue is still there in my Xubuntu 13.04x64 install that I use now. I am also using driver 310.44. I have rolled back from 313 since I didn't find it stable.

    Without the xorg.conf mod I get tearing (OK, not too much, but enuf to annoy me), but with the Option "Composite" "Disable" line all tearing is gone. My xorg.conf is generated by nvidia-settings GUI (except last 3 lines which are my mod) and it looks like this:
    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 313.30  (buildd@lamiak)  Wed Apr 10 17:19:51 UTC 2013
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Samsung SyncMaster"
        HorizSync       30.0 - 81.0
        VertRefresh     56.0 - 75.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GT 520"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "metamodes" "nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Extensions"
      Option "Composite" "Disable"
    EndSection
    IMHE, having dealt with video tearing for years now, it's all to do with the interaction between the video driver and desktop compositing. I am using XFCE which uses xfwm4 as compositor, so there's not much point comparing your and my systems. I am sure KDE (never used it) has MUCH more fancy compositing in place so I think you're best off posting in a KDE specific forum or xbmc. The latter group are a very helpful bunch and heavy Linux users so u have a good chance of getting specific advice there. Overall though I have found that testing different proprietary drivers and turning off everything to do with compositing/3D nearly always fixes the issue completely.

    T

  6. #16
    Join Date
    May 2008
    Location
    The Netherlands
    Beans
    2,149
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: Nvidia GTX 760

    Update, I am working on XBMC and Nvidia forums. Will let you know what happens. Thanks for your help.
    DeMus

  7. #17

    Re: Nvidia GTX 760

    I'd think you'll need to find a way to turn off compositing/desktop effects, ect. or use compiz/emerald instead of kwin
    (compiz 0.9.x by default should eliminate tearing on most setups thru it's default enabled OpenGl settings of
    Framebuffer object
    Always use buffer swapping


    edit:
    You could look at some of the various attempts thru out this thread, you never know...
    http://www.kubuntuforums.net/showthr...nvidia-tearing
    Last edited by mc4man; October 16th, 2013 at 02:44 PM.

  8. #18
    Join Date
    May 2008
    Location
    The Netherlands
    Beans
    2,149
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: Nvidia GTX 760

    I did switch of compositing/desktop effects all together, did not change a thing.
    I saw I could install driver 319.49, did not change a bit.
    How do I change the buffer swapping thing?

    I also took a look at the page you recommended, but found nothing I had not done already. I am speechless.
    Why does this happen? What is wrong with my system?

    Thanks mc4man for your advice.
    DeMus

  9. #19

    Re: Nvidia GTX 760

    I went ahead & did a kubuntu install (13.04) but i fear what I found may be less than helpful for your hardware.
    Atm I only have 2 laptops, the one with a fairly recent nvidia card (660m) is of no value here as there seems to be no practical way to test video thru the nvidia adapter in linux (and the intel adapter, with some addons, works quite well.

    So the only other machine here has an older, nvidia only adapter (8400m, nv50 in nouveau
    On that machine video tearing is non existent by default with nouveau unless I disable vsync in the kwin setting. Part of the reason why is nouveau supports vsync in nv50 family cards, whether your card is likewise supported in nouveau I'm not sure though probably not at the moment. (have you tried nouveau?

    As far as nvidia drivers -
    I tried the 304 drivers as I know vsync in OpenGl is default enabled, available in nvidia-settings & figured there was no 'adaptive vsync' ( if adaptive vsync is in later nvidia drivers it could work against you in video payback
    Again, like nouveau, there was no video tearing on the Desktop, scrolling in large files or in video's (using a tear test video), with the default settings of vsync enabled in kwin & vsync enabled in nvidia settings > OpenGl

    This was again confirmed by disabling vsync in kwin which brought about tearing in all 3 area's.
    (I also tested the option in kwin to disable desktop effects in fullscreen which worked fine to eliminate tearing while vsnc was disabled (ie. tearing present in window mode

    So maybe try the nvidia-304 or nvidia-304-updates, whether your card is supported I don't know, maybe ck. first. Otherwise try the nvidia-310 drivers
    (if unsure if your card is supported with those drivers & trying anyway then be prepared to remove the driver & /etc/X11/xorg.conf from recovery if need be, pretty straightforward procedure

    If still no go & no value for you in nouveau it's possible your card may get kernel side support for vsync in nouveau in the near future, again not really sure.
    Otherwise you may get some relief if you used compiz instead of kwin though not sure you want to do that?/
    Last edited by mc4man; October 17th, 2013 at 04:11 AM.

  10. #20
    Join Date
    May 2008
    Location
    The Netherlands
    Beans
    2,149
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: Nvidia GTX 760

    Man, you have been busy for me, haven't you? Well thank you very much.
    It looks like the problem is solved. I just watched a video with fast horizontal movements and I didn't see the tearing anymore.
    The situation I have now is this:

    Driver: xserver-xorg-video-nouveau, Version 1:1.0.7-ubuntu1

    Desktop effects: enabled, improved window management, various animations, compositing type: OpenGL, QT graphics system: native, Suspend desktop effects for full screen windows, Use Vsync.

    xorg.conf file (whether in use or not I have no idea, guess not since it does mention the Nvidia driver)
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings: version 304.51 (buildd@batsu) Fri Oct 12 12:53:54 UTC 2012




    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "0"
    EndSection


    Section "Files"
    EndSection


    Section "InputDevice"


    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection


    Section "InputDevice"


    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
    EndSection


    Section "Monitor"


    # HorizSync source: edid, VertRefresh source: edid
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "LG Electronics 24EN43"
    HorizSync 30.0 - 83.0
    VertRefresh 56.0 - 75.0
    Option "DPMS"
    EndSection


    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GK104"
    EndSection


    Section "Screen"
    # Removed Option "metamodes" "nvidia-auto-select +0+0"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TripleBuffer" "True"
    Option "Stereo" "0"
    Option "nvidiaXineramaInfoOrder" "DFP-0"
    Option "metamodes" "1920x1080_60 +0+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection


    mc4man and TiberiusT, thank you both so much for helping me out. You guys are great.
    Thanks.
    DeMus

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •