Results 1 to 6 of 6

Thread: apache2 ubuntu

  1. #1
    Join Date
    Sep 2013
    Beans
    20

    apache2 ubuntu

    how do you define your server to listen to your own IP adress and port 8080?
    where is defined ( the file location and name) on dedicated server by default allowed number of requests?
    where is defined (the file location and name) server TimeOut value and what does it mean?

  2. #2
    Join Date
    Jun 2009
    Location
    0:0:0:0:0:0:0:1
    Beans
    4,722
    Distro
    Xubuntu

    Re: apache2 ubuntu

    /etc/apache2/ports.conf
    you can run multiple ports for the same thing, if you want to
    i think you are looking for line 96 of /etc/apache2/apache2.conf
    Last edited by pqwoerituytrueiwoq; September 28th, 2013 at 05:34 PM.
    Laptop: ASUS A54C-NB91 (Storage: WD3200BEKT + MKNSSDCR60GB-DX); Desktop: Custom Build - Images included; rPi Server
    Putting your Networked Printer's scanner software to shame PHP Scanner Server
    I frequently edit my post when I have the last post

  3. #3
    Join Date
    Sep 2006
    Beans
    8,627
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: apache2 ubuntu

    All your settings are found in your default virtual host's configuration file. Unless you've changed or added anything, that should be /etc/apache2/sites-enabled/000-default.conf

    The ports your server listens on are set in /etc/apache2/ports.conf. Just change the line or add another. Your VirtualHost directive in your vhost configuration file will have to match what you are listening on. In other words, the setting must be made in two files.

    The TimeOut settings are something that you can change.

    You'll have to have the server reload for any changes to take effect.

    Code:
    sudo service apache2 reload

  4. #4
    Join Date
    Sep 2013
    Beans
    20

    Re: apache2 ubuntu

    thanks

  5. #5
    Join Date
    Sep 2013
    Beans
    20

    Re: apache2 ubuntu

    what about first question, i thought i can define port by command? but im not sure is correct : Listen 8080 or just Listen 80

  6. #6
    Join Date
    Sep 2006
    Beans
    8,627
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: apache2 ubuntu

    The port to listen to is set in ports.conf If you want to serve data on port 8080 instead of port 80 then you need to remove the line that says "Listen 80" and replace it with a line that says "Listen 8080" Then have the server reload your configuration for the changes to take effect.

    Another thing which might come in handy both now and later is testing the config file for correct syntax.

    Code:
    apache2ctl configtest
    Doing that after major changes will help find any mistakes. Of course it is possible to still make mistakes, but that will catch the obvious ones.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •