Results 1 to 4 of 4

Thread: Ubuntu 13.04 (64bit) dual boot with Windows 8. GRUB no longer working

  1. #1
    Join Date
    Apr 2006

    Ubuntu 13.04 (64bit) dual boot with Windows 8. GRUB no longer working

    Hi. First time poster, long time reader. There is ALWAYS information on the net that gets me to my solution, however this time I am lost, and don't want to spend another 8 hours trying to figure this one out. Any assistance greatly appreciated.

    I have screwed up my GRUB2 boot loader. I just get a flashing cursor when booting up. I am now booting up from a Ubuntu 13.04 64 bit USB key.

    I have attempted running boot-repair a couple of times with the standard settings, a couple of times with the advanced settings. I have also tried manually reinstalling the grub and running update-grub... Following these instructions I have tried everything within my limited technical knowledge and a lot of googling.

    Here is the output of my latest run:

    Firstly, i acknowledge the partitions are a bit all over the place, as this is a lenovo X1 that had Windows 8 pre installed on it. I have moved a few partitions around, and Ubuntu was working fine, but i went in and changed some grub settings, confirmed they were working, then i changed something (i don't remember what specifically i changed) and it no longer works...

    From looking at the URL of the report that was generated by the boot-repair tool, the issue seems that the boot loader is looking for the core.img at sector 235358208 but it’s actually at 108013576. Can i just change that? If so, how?

    I am using my system in legacy mode (not EFI) and i have safe boot turned off.


  2. #2
    Join Date
    Sep 2013

    Re: Ubuntu 13.04 (64bit) dual boot with Windows 8. GRUB no longer working

    I had same problem here with windows 7.

    I tried boot-repair with recommended options several times and persistence paid. System is fine now.
    Last edited by xrules2; September 26th, 2013 at 09:34 AM.

  3. #3
    Join Date
    Apr 2006

    Re: Ubuntu 13.04 (64bit) dual boot with Windows 8. GRUB no longer working

    OK... I have it working.. There was really no method in my approach, as i could not find any understandable instructions online that addressed my issues.

    I updated the BIOS settings to boot from UEFI first (previously it was Legacy first, which WAS working).

    I downloaded the boot-repair iso file here then created a bootable USB key using Universal-USB-Installer- from here

    Once i did this, i booted into boot-repair and ran through the advanced setup options, selected to reinstall the GRUB completely. I was prompted to run a number of scripts manually (chroot etc).

    This worked... So your advice, xrules2 to "keep on persisting" kindof worked.. Seems like it was just that BIOs setting that needed changing... I still think i am none the wiser about this issue though... Will read up on the grub a bit more.

  4. #4
    Join Date
    Jun 2009
    SW Forida
    Ubuntu 16.04 Xenial Xerus

    Re: Ubuntu 13.04 (64bit) dual boot with Windows 8. GRUB no longer working

    It looks like you have grub installed with both BIOS boot which uses gpt's protective MBR and bios_grub partition and UEFI boot which has grub in efi partition. How you install or reinstall/repair grub is which version gets updated. I do not think you can have both grub-pc (BIOS) and grub-efi(UEFI) installed at the same time.
    Boot-Repair will install either depending on how you boot, or can convert a UEFI install to BIOS or BIOS install to UEFI. May be part of the persistence and choosing correct choices, which now are many or can be confusing even if you know what you are doing.
    Without secure boot Ubuntu just installs and works on many systems, but secure boot and all the additional options, and some vendors not exactly following UEFI standards make it difficult.

    You do need to have fast boot off in Windows. It will not boot as quickly, but you will avoid corruption issues. Best to make a UEFI repair flash drive for Windows while system is working.
    Windows 8 UEFI repair USB must be FAT32
    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts