Results 1 to 6 of 6

Thread: Dependency is not satisfiable: ia32-libs

  1. #1
    Join Date
    Apr 2011
    Location
    3rd Rock from the Sun
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Dependency is not satisfiable: ia32-libs

    I am trying to install a 32bit proprietory software.deb and Software Center reports:
    Dependency is not satisfiable: ia32-libs
    I have skype and few other 32bit applications installed, so I am not sure what is going on. I have multiarch enabled in my repos.
    I had read that 'ia32-libs' are being phased out. could this be the case? What is the possible workaround, if true?

    Regards....
    "Evolution is Nature's way of issuing upgrades."


  2. #2
    Join Date
    Jun 2007
    Beans
    16,470

    Re: Dependency is not satisfiable: ia32-libs

    ia32-libs is past "being phased out", it's gone.
    It was just a meta-package so your software provider needs to adjust their debian/control file to use the actual package deps, & remove ia32-libs from it.

    (if inclined you can unpack your .deb, edit out the ia32-libs dep, rebuild the .deb & try to install, noting that you'll need to manually insure that all needed deps are present.

  3. #3
    Join Date
    Apr 2011
    Location
    3rd Rock from the Sun
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Dependency is not satisfiable: ia32-libs

    Thanks for the information.

    I tried the i386.deb of the same application and it Installed fine. The problem was with amd64 package.

    Regards...
    "Evolution is Nature's way of issuing upgrades."


  4. #4
    Join Date
    Jul 2014
    Beans
    1

    Re: Dependency is not satisfiable: ia32-libs

    I have the same problem.

    if inclined you can unpack your .deb, edit out the ia32-libs dep, rebuild the .deb & try to install, noting that you'll need to manually insure that all needed deps are present.
    I loaded the ia-32-avast-libs.deb and got the error.
    What should I exactly edit out how can I do the rebuild?

  5. #5
    Join Date
    Dec 2012
    Location
    Fancy Gap Virginia
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Dependency is not satisfiable: ia32-libs

    Greetings,
    I was having the same problem with Teamviewer. My solution that worked was to do a complete removal of the already installed software using Syanptic and then right click on the deb file and install with Software Center. It almost seems to me that Synaptic does a better job at removal and Software Center does a better job of resolving dependencies. Be sure to choose "completely remove" in Synaptic. Good Luck.
    rrnbtter
    Life is good! Live it to the Ubuntu-ist!
    (With Proposed enabled!)

  6. #6
    Join Date
    Jul 2007
    Location
    Magic City of the Plains
    Beans
    Hidden!
    Distro
    Xubuntu 17.10 Artful Aardvark

    Re: Dependency is not satisfiable: ia32-libs

    Hi chrisi.egg, if you're using 14.10 please start a new thread; if using 14.04 or earlier please post in the regular support areas of the forum.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •