Results 1 to 2 of 2

Thread: GNU command line grub in ubuntu 12.04 LTS

  1. #1
    Join Date
    Sep 2013

    GNU command line grub in ubuntu 12.04 LTS

    Hi all,

    I have a 1 TB HP Hdd with a preinstalled windows 8 OS. I installed ubuntu 12.04 LTS and during the installation, i encountered an error that the grub2 had failed to install. So i did a boot repair and now, i am stuck with a command line GNU grub. I am not able to log in to windows and i am working on ubuntu live using the USB. Here is a copy of the file i received on using the boot repair tool. I can see that there are some errors but i am unsure as to how to rectify them without deleting data from windows.


  2. #2
    Join Date
    Jun 2009
    SW Forida
    Ubuntu 16.04 Xenial Xerus

    Re: GNU command line grub in ubuntu 12.04 LTS

    The main error I see is that grub menu has no boot entries. Grub2's os-prober normally creates entries for Ubuntu and Windows. The Windows entries from prober are wrong but then Boot_Repair creates correct entries in 25_custom and it could not create that file. More like grub was not ever installed?

    It also looks like you tried to install wubi, which does not work with gpt partitioned drives (all UEFI systems). You can just uninstall it or delete it from Windows.

    It may be easiest to just try a new install? If you try that either use gparted on live installer to delete Ubuntu partition or use Something Else or manual install to choose existing sda6 as /.
    But I prefer to have smaller system / (root) partition of 25GB and separate /home. With Windows you may want to have a shared read/write NTFS data partition. Windows 8 in particular should not be written into from any other system even anther Windows install, but can be set as read only when mounted in Ubuntu.
    Also make sure fast boot is off in Windows 8.

    WARNING for Windows 8 Dual-Booters
    It defaults shutdown to a hybrid hibernation/off state for fast boot
    But then files may be corrupted similar to Windows 7 Hibernation:
    Fast Startup off/hibernation
    Force removal of hiberfil from Ubuntu
    User who fixed Windows 8
    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts