Copying info from askubuntu: http://askubuntu.com/questions/34344...ects-in-ubuntu

I am trying to connect to my uni's public wifi in ubuntu. After an initial attempt that is usually successful, the connection drops after a few minutes (sometimes < 1). After that future attempts to connect may or may not be successful, but after a few initial successes I find myself completely unable to connect.


I had this issue with this laptop before. I ended up buying and installing a new wifi card and (if I remember correctly) installing the proprietary drivers for it, which seemed to fix the issue. However, after reinstalling ubuntu over the summer the problem has re-surfaced, and now I can't seem to find the proprietary drivers I thought I had installed when I last had this issue.


I do not have connectivity issues in windows on this laptop, so I'm pretty sure this is a software/driver issue.


This is my wifi card's lspci entry:

03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)

and my lsmod: http://paste.ubuntu.com/6041598/


I tried implementing the solution mentioned here: Very slow connection on an Intel(R) WiFi Link 5100 AGN, which did not help my connectivity issues.

Also see the askubuntu thread linked at the top for some other things I've tried that didn't help.