Page 4 of 4 FirstFirst ... 234
Results 31 to 37 of 37

Thread: BCM4313 driver not working under various drivers in Ubuntu 13.04.

  1. #31
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,136
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: BCM4313 driver not working under various drivers in Ubuntu 13.04.

    [EDIT: A better way to do what is suggested in this post (with cleanup if required): http://ubuntuforums.org/showthread.php?t=2181558
    Post #1 is the workaround/fix to the Hard blocked problem, #2 is a workaround to the Fn+F2 hotkey
    Thanks to pixolex for linking this to his bug report
    ]

    Quote Originally Posted by shao2 View Post
    Your trick failed...
    I wasn't holding my breath, but..... YAY (to the latter part, not the above quoted one..) !!

    Please try this -
    Code:
    echo "options asus_nb_wmi wapf=0" | sudo tee /etc/modprobe.d/asus_nb_wmi.conf
    (reference post)

    Then remove the driver from blacklist -
    Code:
    sudo sed -i '/asus_nb_wmi/ d' /etc/modprobe.d/blacklist.conf
    Reboot and check if it's loaded (lsmod | grep asus). It should, but is the hardblock back again too? If it is, change the parameter "wapf=0" to "wapf=1" -
    Code:
    sudo sed -i 's/0/1/' /etc/modprobe.d/asus_nb_wmi.conf
    Reboot and check again. If the hardblock is still there, try changing "1" to "4" this time -
    Code:
    sudo sed -i 's/1/4/' /etc/modprobe.d/asus_nb_wmi.conf
    Once more, reboot and let us know the result.

    Make sure you try the values 0,1 and 4 in the order given above, else the sed command won't work (unless you change the "pattern to search" accordingly).

    EDIT:
    Try the Fn+F2 combination after each reboot. That is what is supposed to be corrected by above parameters, as well as the wifi block state at startup.
    Last edited by varunendra; October 29th, 2013 at 01:49 AM. Reason: Inserted link to a better way
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  2. #32
    Join Date
    Sep 2013
    Beans
    9

    Thumbs up Re: BCM4313 driver not working under various drivers in Ubuntu 13.04.wmi aus

    Long story short, wifi boots into active state when using "wapf=1" and "wapf=4"

    Here's my method:


    1. Removed the asus_nb_wmi driver from my blacklist
    2. Added the parameter with "wapf=0."
    3. Reboot. Wifi hardblocked
    4. FN+F2 does not work. No pop-up or notification.
    5. Changed parameter to "wapf=1"
    6. Reboot. Wifi active
    7. FN+F2 does not work. No pop-up or notification.
    8. Changed parameter to "wapf=4" (for curiosity's sake)
    9. Reboot. Wifi active
    10. FN+F2 does not work. No pop-up or notification.
    11. Changed parameter to "wapf=0"
    12. Reboot. Wifi hardblocked
    13. FN+F2 does not work. No pop-up or notification.
    14. Changed parameter back to "wapf=1


    FN+F2 (WIFI) never worked before on ubuntu. All my other function keys including FN+F9 (touchpad) works at the moment.

    Thanks, Varun. You've been a great help!

  3. #33
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,136
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: BCM4313 driver not working under various drivers in Ubuntu 13.04.wmi aus

    Quote Originally Posted by shao2 View Post
    Long story short, wifi boots into active state when using "wapf=1" and "wapf=4"

    Here's my method:


    1. Removed the asus_nb_wmi driver from my blacklist
    2. Added the parameter with "wapf=0."
    3. Reboot. Wifi hardblocked
    4. FN+F2 does not work. No pop-up or notification.
    5. Changed parameter to "wapf=1"
    6. Reboot. Wifi active
    7. FN+F2 does not work. No pop-up or notification.
    8. Changed parameter to "wapf=4" (for curiosity's sake)
    9. Reboot. Wifi active
    10. FN+F2 does not work. No pop-up or notification.
    11. Changed parameter to "wapf=0"
    12. Reboot. Wifi hardblocked
    13. FN+F2 does not work. No pop-up or notification.
    14. Changed parameter back to "wapf=1


    FN+F2 (WIFI) never worked before on ubuntu. All my other function keys including FN+F9 (touchpad) works at the moment.
    That's awesome !!

    The results are GREAT, if not Greater than what I could expect. I *may* find some time to look deeper into this (AND someone else may as well). I'll definitely post here if found something worth posting.

    Now that it is in "Always On" condition, I'd suggest you to try this workaround to use hotkeys (or combination of hotkeys) to turn it off/on (soft block) : http://ubuntuforums.org/showthread.p...4#post12787274
    EDIT: Here is a slightly better and smarter way to do the same thing : http://ubuntuforums.org/showthread.p...7#post12819607

    As much as I know, a soft-block state is same as hard-block in terms of power-saving. Both send the card to a "low-power" sleep mode where it consumes only micro-amps of current.

    If you try the above workaround, please do let us know how good or bad it works. And thank you for the testing and sharing the results with us in such a well written manner.

    PS:
    We haven't tested this extensively, but you may try some other values between 1-9 to see if they are accepted. If they are not, the module won't load at startup and will return "wrong parameter" error if you tried to manually load it (sudo modprobe -v asus_nb_wmi). But IF the parameter is accepted, does it make any positive difference to the Fn+F2 combo? If not, you can always set it back to "1". You do know how to use "sed" to do that, right?
    Last edited by varunendra; October 18th, 2013 at 02:24 PM.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  4. #34
    Join Date
    Sep 2013
    Beans
    8

    Re: BCM4313 driver not working under various drivers in Ubuntu 13.04.wmi aus

    Oh my gosh, you've done it! I had honestly given up hope. I cannot thank you enough. If you put up a paypal donation link I might be willing to offer you a little something for your work

  5. #35
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,136
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: BCM4313 driver not working under various drivers in Ubuntu 13.04.wmi aus

    Quote Originally Posted by Luke_Ender View Post
    Oh my gosh, you've done it! I had honestly given up hope.
    So it worked for you too? That would be a paycheck in itself for me ! (/me grins from ear to ear with some suspense in mind..)

    If it did, how about marking the thread as [SOLVED] now so that others looking for help on the same issue may realize these four pages may be worth it ?

    PS:
    If you put up a paypal donation link I might be willing to offer you a little something for your work
    Thank you so much for the generous offer, but I'm sure the admins will kick me off the forums the very day I started putting up links asking for donations
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  6. #36
    Join Date
    Sep 2013
    Beans
    9

    Re: BCM4313 driver not working under various drivers in Ubuntu 13.04.

    I finally found some time to test out the different "wapf=" options. I tested "wapf=0" all the way to "wapf=9". From what I've gathered, every value from 1-9 worked and zero was the only one that did not give me an active wifi state.

    PS:
    We haven't tested this extensively, but you may try some other values between 1-9 to see if they are accepted. If they are not, the module won't load at startup and will return "wrong parameter" error if you tried to manually load it (sudo modprobe -v asus_nb_wmi). But IF the parameter is accepted, does it make any positive difference to the Fn+F2 combo? If not, you can always set it back to "1". You do know how to use "sed" to do that, right?

  7. #37
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,136
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: BCM4313 driver not working under various drivers in Ubuntu 13.04.

    Quote Originally Posted by shao2 View Post
    I finally found some time to test out the different "wapf=" options. I tested "wapf=0" all the way to "wapf=9". From what I've gathered, every value from 1-9 worked and zero was the only one that did not give me an active wifi state.
    Hmm.. with Fn+F2 remaining useless all the way I guess.

    Thanks for taking the time to do the tests and let us know the output. I've been referring to your feedback quite often since your last post.

    I posted a thread on this fix yesterday, adding a slightly better than previous method to compensate Fn+F2 : http://ubuntuforums.org/showthread.p...7#post12819607

    And like mentioned twice on that thread, I'd request you too to consider submitting a bug report regarding this as you are an original user facing the problem. I could submit it too, but since I am not an affected user, I can't submit the required logs/reports nor can I test what might be recommended on launchpad to test.

    Thanks again for your continued feedback.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

Page 4 of 4 FirstFirst ... 234

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •