Results 1 to 3 of 3

Thread: vsftpd ignoring user_config_dir setting.

  1. #1
    Join Date
    Sep 2013
    Beans
    1

    Question vsftpd ignoring user_config_dir setting.

    Hello All!

    I'm brand new to Ubuntu server's and I'm getting my feet wet on Ubuntu 13.04 x 64bit.

    I've been working on getting vsftpd installed and I've been able to successfully FTP in using a user I created: "MYUSERNAME". When I FTP in, the default directory is /home/MYUSERNAME. What I'd like it to be is: /var/www/MYUSERNAME. That folder exists and my user has permissions to it.

    My vsftpd.conf file is as below:
    === /etc/vsftpd.conf ===


    listen=YES
    local_enable=YES
    write_enable=YES
    local_umask=022
    chroot_local_user=YES
    user_config_dir=/etc/vsftpd/users
    secure_chroot_dir=/var/run/vsftpd/empty
    pam_service_name=vsftpd
    rsa_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
    rsa_private_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
    userlist_file=/etc/vsftpd.userlist
    userlist_enable=YES
    userlist_deny=NO
    seccomp_sandbox=NO


    And my user config file is:
    === /etc/vsftpd/users/MYUSERNAME ===


    local_root=/var/www/MYUSERNAME
    dirlist_enable=YES
    download_enable=YES
    write_enable=YES


    vsftpd is completely ignoring my settings. On top of all that, I can't seem to write when I FTP in as that user. Any ideas? I've scoured the net for several hours now and none of the "common" fixes (like tweaking user_config_dir and checking permissions) seem to work.

    Thanks in advance!

  2. #2
    Join Date
    Jun 2006
    Location
    Netherlands
    Beans
    22
    Distro
    Xubuntu

    Re: vsftpd ignoring user_config_dir setting.

    Did you restart vsftpd after you changed your configuration file?

    Code:
    sudo service vsftpd restart
    Also add

    Code:
    tcp_wrappers=YES
    to your vsftpd.conf

    As an alternative you try making a simlink in your home directory? Maybe this works.

    Code:
    ln -s /home/MYUSERNAME/www /var/www/MYUSERNAME
    What happens if you put local_root=/var/www/MYUSERNAME to the main vsftpd.conf?
    Last edited by peertje; September 30th, 2013 at 07:02 PM.

  3. #3
    Join Date
    Feb 2008
    Location
    Funky Town, AUS
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: vsftpd ignoring user_config_dir setting.

    Thread moved to Server Platforms.

    Welcome. You might have more luck here.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •