Results 1 to 3 of 3

Thread: Trouble installing Ubuntu 13.04 on MacBook Air 6,1 11" (A1465)

  1. #1
    Join Date
    Jul 2010

    Trouble installing Ubuntu 13.04 on MacBook Air 6,1 11" (A1465)

    I've been trying to install Linux on my MacBook Air Mid 2013 11" (6,1 Model: A1465) for a little while now. My end goal is a penetration testing distrobution such as Kali, which I believe is based on Ubuntu. However my initial attempt failed so I tried to install BackBox linux on the machine, which worked to some degree. However the install wasn't stable and there were various problems. You can read what I went through here:

    So I decided to take a few steps back and get a grasp on installing regular Ubuntu onto the machine alongside OS X.

    I was following the super vague guide here: where the author said he got it up and running, Wi-Fi included on my same machine.
    This is what happened when I tried to install...

    - First I booted into OS X, and made a Time Machine backup of my system
    - Then I opened Disk Utility and on the left side selected the "ubuntu-13.04-desktop-amd64.iso" and clicked "Burn" at the top.
    - The burn completed, verified, and mounted on the desktop
    - When trying to mount it said "The disk you inserted was not readable by this computer"
    - So I clicked "Ignore"
    - I rebooted into an OS X install drive by holding option
    - I used the Disk Utility app on the install drive to erase my disk
    - I selected the root of the drive on the left and went to the partition tab
    - I chose 2 partitions:
    1: Mac OS X Extended (Journled) 230 GB
    2: Free Space 21 GB
    - Applied partitions, done
    - Then I reinstalled Mountain Lion onto the first partiton
    - Install went fine
    - Transferred files back to the partition after install completed
    - Before moving everything back I looked at the "Users" portion of the time machine backup
    - There was a "Fink build system" entry or something similar so I unchecked that
    - Start up, boot into OS X and everything seems fine
    - Reboot, hold option, I see rEFIt is still there from before I restored
    - Reboot into OS X and follow the uninstall instructions here:
    - I removed the /efi partition
    - I removed the /Library/StartupItems/rEFItBlesser
    - Reboot, hold option, now I see:
    - OS X Install
    - Recovery 10.8.4 (Install must have put that there)
    - Windows (with a disk icon)
    - EFI Boot (with a disk icon)
    - EFI Boot (with a disk icon) (Yes, there were two of them)
    - I chose "Windows" (with the disk icon) and then I get a black screen with blinking underscore
    - A bunch of text is scrolling by, some of which I managed to copy down:
    udeud [119]: timeout killing '/sbin/blkid' -o udev ... (missed the rest)

    - Ubuntu splash screen shows up and looks like it's loading
    - A welcome dialog shows up and I click on "Install Ubuntu"
    - At this point I plug in a ethernet -> USB dongle, but it won't recognize I'm connected to the internet
    - I move on with the install, clicking "Continue"
    - I select "Install Ubuntu alongside Mac OS X" then click "Install Now"
    - I select my time zone, keyboard layout, and set up the user account
    - At the bottom it says "Copying files..."
    - After a while a dialog box pops up and it says "Installation complete" and I click "Reboot Now"
    - The CD is ejected
    - The keyboard backlight is still on
    - I unplug the external CD drive
    - Then I unplug the ethernet -> USB dongle
    - I press the down arrow and a bunch of text scrolls past the screen super quick and the computer reboots
    - Boot holding option, I now see three choices:
    - Mac OS X
    - Windows
    - Recovery 10.8.4
    - Select Windows
    - I get dropped to a GRUB window
    - I press "e" to edit the default GRUB profile
    - According to Miek, you need to append "nosmp" to the kernel boot parameter or it won't boot up
    - I add "nosmp" to the end of the following line:
    linux    /boot/vmlinuz-3.8.0-19-generic root=UUID=388d53ce-ddab-44e9-a8ea-ob31105f772f ro    quiet splash $vt_handoff
    - Then I press F10 to boot
    - I get a black screen with a blinking _
    - Then I got what looked like an error but didn't have time to write it all down, here's what I scribbled:
    Gave up waiting for root device
    - Then it drops me to a (initramfs)_ prompt
    - While I was copying down the error it started to scroll some lines again, most of the looking very much just like this:
    '/sbin/blkid -o udev -p /dev/sda1' [222] terminated by signal 9 (killed)
    - Then the scrolling stops and I'm back at the (initramfs)_ prompt
    - I typed exit and this was displayed:
    Gave up waiting for root device. Common problems:
        - Boot args (cat /proc/cmdline)
            - Check rootdelay= (did the system wait long enough)
            - Check root= (did the system wait for the right device?)
        - Missing modules (cat /proc/modules; ls /dev/)
    ALERT! /dev/disk/by-uuid/388d53ce-ddab-44e9-a8ea-0b31105f772f does not exist
    Dropping to a shell!
    BusyBox v1.20.2 (Ubuntu 1:1.20.0-8ubuntu1) built-in shell (ash)
    Enter 'help' for a list of built in commands
    - I reboot holding option, choose Windows and then at GRUB press 'e' to edit the default option
    - At the end of:
    linux    /boot/vmlinuz-3.8.0-19-generic root=UUID=388d53ce-ddab-44e9-a8ea-ob31105f772f ro    quiet splash $vt_handoff

    I add
    nosmp rootdelay=90
    and very briefly on the screen I see something like:
    Booting a command list
    Could not find command
    then a bunch more of that timeout, and killing as before, then I'm dropped into that same BusyBox shell as before so I reboot.

    - Reboot, holding option, Windows > GRUB, 'e' to edit default option and add
    to the end of the kernel line (assuming the kernel line is the one I've been editing)
    - Booting up gives me a kernel panic

    - Reboot, holding option, Windows > GRUB
    - In GRUB, select the advanced options, then select:
    Ubuntu, with Linux 3.8.0-19-generic(recovery mode)
    it locks up when at this line:
    [    0.090497] smpboot: Booting Node 0,    Processors #1
    - Reboot, holding option, Windows > GRUB
    - In GRUB, selected advanced options, then recovery mode, pressed 'e' to edit the options
    - Added nosmpto the end of the kernel parameters
    - Failed to boot, gave me this error:
    udev[103]: '/sbin/blkid -o udev -p /dev/sda2 [215] terminated by signal 9 (killed)

    Now, I'm not exactly sure what to try next. I've Googled just about everything I can think of.
    It's going to be hard to figure this out I'm guessing since it's probably specific to the hardware or something like that. However if anybody has any suggestions I'm down to try them.
    Let's figure this out people!

  2. #2
    Join Date
    Aug 2013

    Re: Trouble installing Ubuntu 13.04 on MacBook Air 6,1 11" (A1465)

  3. #3
    Join Date
    Aug 2007
    a puddle in Manchester
    Ubuntu 14.04 Trusty Tahr

    Re: Trouble installing Ubuntu 13.04 on MacBook Air 6,1 11" (A1465)

    Is 388d53ce-ddab-44e9-a8ea-0b31105f772f the UUID of the partition you have installed Ubuntu to? Which is /dev/sda2 - correct? I would have thought /dev/sda2 was your Mac OSX partition.
    It's often wise to boot the cd/usb and select try Ubuntu first so that you can then experiment with boot arguments before installation - so you'll know what is needed.
    Last edited by Quackers; September 17th, 2013 at 04:36 PM.
    MacBook Pro 10,1 retina


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts