This is an answer for the question that was asked in this thread:

Quote Originally Posted by josephellengar the September 23rd, 2011
I installed kmymoney in gnome, so I can't use the KDE control center to turn off the sound effects. I don't even have KDE installed. Is there any way to turn off the sounds effects?

Thanks!
The sound effects in KDE applications must be turned off at KDE system administation level.

First way: You can install the KDE administration interface, it's about 1kB:
Code:
sudo apt-get install systemsettings
Then run it:
Code:
systemsettings
Click on Application and System Notifications, Player Settings, select the No audio Output radio, and then the Apply button.

Second way: If you don't wish to install a stupid administration interface just to get rid of such anoyance, you can also try this:

Edit the ~/.kde/share/config/knotifyrc file and add:

Code:
[Sounds]
No sound=true
Use external player=false
Volume=100
Just for the record, here is my ~/.kde/share/config/knotifyrc:

Code:
[Misc]
LastConfiguredApp=Accessibility

[Phonon::AudioOutput]
KNotify_Volume=1

[Sounds]
No sound=true
Use external player=false
Volume=100
If you are a paranoid like me, you may also want to copy this file into /usr/share/kde4/config.