Results 1 to 2 of 2

Thread: No boot on chinese laptop

  1. #1
    Join Date
    Sep 2013

    No boot on chinese laptop

    Hello, I am a european boy living in Shanghai(China), couple days ago I bought a Toshiba Qosmio X70 here. I clearly had chinese OS so I decided to install ubuntu and english windows 8(I could not change the language from the options).
    I had usb sticks of both of them but even changing the BIOS booting options the pc would boot the chinese OS.
    So I burned a DVD with ubuntu but after the initial menu the laptop would get stuck on a black screen. Same happened with the Windows stick(except it would stuck on the "starting windows" screen).
    So I tried to change the BIOS, but the only one available on the official site was 1.0 version meanwhile I have 1.1 version and the .exe bios flashing program says it's not compatible.
    Can someone please help me? I don't know what to do, I paid a lot for this pc and I feel like I wasted the only money I had on it.

  2. #2
    Join Date
    Mar 2010
    Ubuntu 12.04 Precise Pangolin

    Re: No boot on chinese laptop

    Hello, and Welcome to the Forums federico3 !

    Being a new system, it is almost certainly UEFI based. Does it have Windows 8 preinstalled? If so, it must have "Secure Boot" enabled. Disable it from the UEFI setup or from within Windows, whichever is applicable :

    Then try booting again with the USB. If installing in UEFI mode, you must use 64 bit Ubuntu.
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts