Results 1 to 2 of 2

Thread: "No Boot Device Available" after running Boot-Repair

  1. #1
    Join Date
    Sep 2013

    "No Boot Device Available" after running Boot-Repair

    I have Dell Inspiron with pre-installed UEFI enabled Windows 8. I created a live USB to install Ubuntu 13.04.

    After installing Ubuntu I restarted my machine but it didn't display any Boot option and started Windows 8.

    Then I restarted my machine with Ubuntu Live USB and installed the Boot-Repair.

    I selected the Recommended Repair option.

    It displayed a message "Please disable SecureBoot in the BIOS. Then try again. Do you want to continue?". I selected Yes without disabling the SecureBoot (Sorry my fault)
    Latter on it displayed message "buggy-kernal detected. Do you want to activate[Backup and rename Windows EFI files]". I selected 'Yes'.

    But now I can't boot in any OS. It displays "No boot device available"

    Please find below the link from Boot Repair tool.

    P.S:- I am absolutely newbie in Ubuntu world.

  2. #2
    Join Date
    Jun 2009
    SW Forida
    Ubuntu 16.04 Xenial Xerus

    Re: "No Boot Device Available" after running Boot-Repair

    A lot of users with Dells seem to have worked. Have you turned off secure boot and in UEFI menu tried to boot the ubuntu entry?

    Dell 14z & 17r with Intel SRT
    Dell UltraBook - Instructions & Details in Post #15 & 16 Devine Shine
    Installing Ubuntu 12.10 x64 on Dell XPS 13 Alongside Windows from USB New user with Details post 10
    Dell Inspiron 17R SE - 12.04.2 but otherwise similar to XPS13 above
    Dell XPS 14 Ultrabook what works
    Dell 14z used Dell Recovery and Refind

    This says you have Windows set as boot. BootInfo has three of these from UEFI data, but I do not know which is which. I think one is just secure boot which only shows those systems that are secure boot, the other is UEFI. Not sure if the third is CSM or just history of last boot.

    BootOrder: 0001,2001,0004
    Boot0000* UEFI Onboard LAN IPv4 ACPI(a0341d0,0)PCI(1c,0)PCI(0,0)MAC(b8ca3ae1d39e,0 )IPv4(<->,0, 0RC
    Boot0001* Windows Boot Manager HD(1,800,fa000,b6eab9be-c43c-48d7-bd1c-94eacf51f275)File(EFIMicrosoftBootbootmgfw.efi)WIN DOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6 .2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}....................
    Boot0002* UEFI Onboard LAN IPv6 ACPI(a0341d0,0)PCI(1c,0)PCI(0,0)MAC(b8ca3ae1d39e,0 )030d3c0000000000000000000000000000000000000000000 00000000000000000000000000000000000004000000000000 000000000000000000000RC
    Boot0003* EFI USB1 PATH1 (KingstonDataTraveler G3) ACPI(a0341d0,0)PCI(1d,0)USB(0,0)USB(2,0)HD(1,1f80, eea080,c3072e18)RC
    Boot0004* Ubuntu HD(1,800,fa000,b6eab9be-c43c-48d7-bd1c-94eacf51f275)File(EFIubuntugrubx64.efi)RC
    Boot2001* EFI USB Device RC
    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts