Results 1 to 2 of 2

Thread: Shotwell broken - "unable to update photo library"

  1. #1
    Join Date
    Aug 2013

    Question Shotwell broken - "unable to update photo library"

    Hi helpful folks,

    I'm having a Shotwell problem. It all started when I needed to do a clean install of Linux Mint 15 (I know this isn't Ubuntu but I figured there are enough similarities that y'all might be able to help - no luck on the Mint forums so far). I backed up the Home directory and Application List using the Linux Mint Backup Tool, then created a Live USB and did a clean install of Mint.

    After the install, I restored the Home directory and applications list. Everything worked fine - until I tried to launch Shotwell and got the following error message:

    Shotwell was unable to upgrade your photo library from version 0.13.0 (schema 16) to 0.14.1 (schema 19). For more information please check the Shotwell Wiki at
    The application does not launch. I googled the text and found this site:

    I followed the instructions and updated the permissions (which were mis-assigned), but the problem remains. This is my parents computer and I want to save their photo library if I can! Any ideas on how to fix this? Thank you!

  2. #2
    Join Date
    Aug 2013

    Re: Shotwell broken - "unable to update photo library"

    Can anyone help? I don't want to lose all the work that my dad has done over the past year to build that photo database.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts