Hi helpful folks,

I'm having a Shotwell problem. It all started when I needed to do a clean install of Linux Mint 15 (I know this isn't Ubuntu but I figured there are enough similarities that y'all might be able to help - no luck on the Mint forums so far). I backed up the Home directory and Application List using the Linux Mint Backup Tool, then created a Live USB and did a clean install of Mint.

After the install, I restored the Home directory and applications list. Everything worked fine - until I tried to launch Shotwell and got the following error message:

Shotwell was unable to upgrade your photo library from version 0.13.0 (schema 16) to 0.14.1 (schema 19). For more information please check the Shotwell Wiki at http://redmine.yorba.org/projects/shotwell/wiki
The application does not launch. I googled the text and found this site:

I followed the instructions and updated the permissions (which were mis-assigned), but the problem remains. This is my parents computer and I want to save their photo library if I can! Any ideas on how to fix this? Thank you!