Results 1 to 9 of 9

Thread: Unable to Execute VLC from PHP

Threaded View

  1. #1
    Join Date
    Aug 2013
    Beans
    5

    Unable to Execute VLC from PHP

    I am running uBuntu 12.04.3, 32 bit OS on a 8 CPU, 8GB RAM 64-bit Intel Xeon machine. I have installed all backports as well.

    I have this problem which is eating my head for the last 3 days. I created a play.sh file with the following code...

    Code:
    #! /bin/sh
    vlc -vvv sasural.ts
    Where sasural.ts is a video file that resides under home and in the same level as Apache. I am invoking the .sh file by using the following PHP code...

    Code:
    shell_exec('play.sh');
    I also tried both the exec() / system() methods to invoke the .sh file.

    Whenever I do so, I get the following message...

    VLC media player 2.2.0-git Weatherwax Command Line Interface initialized. Type `help' for help. > Shutting down.

    play.sh works if I execute it from the terminal command prompt outside of the PHP code. I guess I am doing something wrong when I invoke it from within PHP.

    I have linked all directories in Apache, etc. tried every trick in the book but to no avail! I am losing my brains and my nuts over this issue! Is there anybody out there who knows what is going on?


    Last edited by Seemant_Shankar; August 26th, 2013 at 03:05 PM. Reason: Added system and OS specifications

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •