Hello.
I've tried to install ROS for the last two days, followed a few guides, tried to type in the installation commands in the ubuntu terminal a thousand times.
I have virtualbox installed I have the extension packages installed I have installed ubuntu 12.04 I have checked: mail, universe, restricted and multiverse in the software sources and unchecked the installable cd/dvd. I have updated in terminal by executing the sudo apt-get update command
everytime I enter this command: sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu precise main" > /etc/apt/sources.list.d/ros-latest.list'
Nothing happens, just a new line with: ubuntu@ubuntu:~$ starts.

some of the tutorial is from here:

https://www.robotappstore.com/Knowle...Users/137.html

http://nootrix.com/2012/09/virtualizing-ros/

http://nootrix.com/2012/05/ros-installation/



Another isues I also have is my keyboard has all the special signs like: _/(=&/¤*^" etc. swicted around, so I have to guess where they know are hidding even through I have my own country keyboard layout configurated, so what can that be all about?
Im so frustrated right now, so hope somebody can help me, I have tried google alot without any concrete help.
Best regards.