Results 1 to 2 of 2

Thread: Login screen alignment is waaaayyy off after new install (HIS Radeon HD 6570 Silence)

Hybrid View

  1. #1
    Join Date
    Jan 2009

    Login screen alignment is waaaayyy off after new install (HIS Radeon HD 6570 Silence)

    I have installed the Ubuntu 13.04 amd64-version on a brand new computer. I have bought a similar computer for my father a few weeks ago with the only difference being the graphic card and the power supply. His didn't have any problems after installation, so I suspect it is the driver for the graphic card. Here is a screenshot of how it looks like:

    So this is much more than just adjusting the alignment with a button on the monitor. What has been installed is the 64-bit version of Ubuntu (the same as my father's installation). But here the graphic card is a "HIS Radeon HD 6570 Silence". During the setup, I selected the 3rd-party software and to automatically download updates during installation. Now I can't get past the login screen, but can get to a command prompt by using the CTRL+Alt+F2. Does anyone have an idea of how to fix this?
    Last edited by knud200; August 25th, 2013 at 04:11 PM. Reason: Solved

  2. #2
    Join Date
    Jan 2009


    The problem has been solved. I needed to manually download and install the driver. Here is what to do:

    1. Boot up the new installation to the login screen.
    2. Press Ctrl+Alt+F2 to get to a command prompt and log in with your credentials.
    3. Download the driver
    4. Unzip the driver
    5. Make the script executable
      chmod u+x
    6. Run the script with administrator privileges. I followed the recommended settings, basically pressing enter the whole time.
      sudo ./
    7. Reboot the computer. After startup, the new Ubuntu installation should work.
      sudo reboot

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts