Page 176 of 203 FirstFirst ... 76126166174175176177178186 ... LastLast
Results 1,751 to 1,760 of 2026

Thread: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

  1. #1751

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    @mimiba - question...if your hbd..1 is just your xp system os, then why do you need to mount it?
    also, you could try this command to mount since i noticed there are non-english characters in your output..
    Code:
    sudo mount -t ntfs-3g /dev/mapper/nvidia_hbdhjhac1 /media/Windows -o locale=hu_HU.utf8
    this makes filenames with non-english characters visible and might be your problem. of course that is assuming from your output that there are non-english character filenames.

    also if that doesnt work try this:
    Code:
    sudo mount -t ntfs-3g /dev/mapper/nvidia_hbdhjhac1 /media/Windows -o locale=hu_HU.utf8 errors=recover defaults
    also i noticed that your win95 extended partition contains both your ntfs partition, linux swap and ext3. This may be the issue itself. Since your lucky and seemed to have ordered your ntfs partion at the very end of the drive it will be simple to fix. Grab that annoying win98 boot disk with fdisk on it, and repartition your drive to the following layout:
    Code:
                    所用裝置 Boot      Start         End      Blocks   Id  System
    /dev/mapper/nvidia_hbdhjhac1   *           1        2550    20482843+   7  HPFS/NTFS
    /dev/mapper/nvidia_hbdhjhac2            2551       7267   140343840    f  W95 Ext'd (LBA)
    /dev/mapper/nvidia_hbdhjhac6            2551        2673      987966   82  Linux swap / Solaris
    /dev/mapper/nvidia_hbdhjhac7   *        2674        7267    36901273+  83  Linux
    /dev/mapper/nvidia_hbdhjhac8            7268       20022   (w/e the blocks are)    f  Extended LBA number 2
    /dev/mapper/nvidia_hbdhjhac9            7268       20022   102454506    7  HPFS/NTFS
    where hac8 is another extended partition, hac9 is the logical partition on the new extended partition. The first extended partition remains, simply removing the ntfs partition, leaving the two logical linux and swap partitions untouched.
    you should be able to accomplish this without erasing any data on your linux partiton, but your ntfs partition will most likely be smoked. So youll need to make a backup of anything you want to keep. And just to be safe, if you take this course of action, make a back up of everything you want to keep just in case!

    -----------------------------------------------------------------------
    @atmartin - hmm, since you are hibernating windows and switching to linux, this may be what is causing the problem. whenever ntfs partitions are mounted, a logfile is created and saved with changes made about the data, etc. however, since your only hibernating it seems that xp is not writing and closing that logfile, leaving linux unable to access it since its still in use. Have you tried booting in linux first, hibernating, and booting into xp, then hibernating back into linux when you want?

    im assuming you want to be able to write to your ntfs partition since your here, so the ro option is completely useless to you. At the moment, this is all that i can think of to solve the problem. If i find something ill be sure to get back asap if the above doesn't work.
    I personally dislike hibernating greatly after an incident before i used linux, where i lost around 80gb of personal documents and music after trying to wake my computer from hibernation and getting a bsod x.x

    also when you use mount and pmount, make sure that after your device (/dev/sda1) that you have a mount point (like /media/windows or /media/whatever)
    Last edited by platinummonkey; June 19th, 2007 at 04:54 PM.

  2. #1752
    Join Date
    Nov 2005
    Location
    Hungary
    Beans
    146

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Quote Originally Posted by mimiba View Post
    But follows the problem, when I use the same method to mount /dev/mapper/nvidia_hbdhjhac5
    It failed..........
    You weren't mounting with ntfs-3g but with the kernel NTFS driver. Change the 'ntfs' file system type to 'ntfs-3g' in your fstab.

  3. #1753
    Join Date
    Mar 2007
    Location
    Greensboro, NC, USA
    Beans
    71
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    platinummonkey:

    Thanks for the idea, but I don't have XP on my machine anymore, having taken the full-Linux plunge about 2 weeks ago. Could it be that the old windows log file that you mentioned still remains, but I'm not seeing it?

    One more question: could you please elaborate on what you mean by this, say, by a specific example? Thanks!

    also when you use mount and pmount, make sure that after your device (/dev/sda1) that you have a mount point (like /media/windows or /media/whatever)
    I really appreciate your help!

  4. #1754

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    thanks szaka, i made a mistake when put that code! ill fix it now sorry about that

    @atmartin - the old logfile could definetly still be there, just corrupted or incorrectly saved.

    an elaboration hmm.. well here is an example of what i meant:
    Code:
    sudo mount -t ntfs-3g /dev/sda1 /media/ntfspartition -o errors=recover defaults
    where "-t ntfs-3g" declares the filesystem type. we declare this using the ntfs-3g tools
    .........."/dev/sda1" is your partition [note!: /dev/sda is your actual hardrive, while the ending number (the 1 in /dev/sda1) represents your partitions]
    .........."/media/ntfspartition" can be any mount point. meaning this is where you would navigate using your file manager to view your files.
    ..........."-o errors=recover defaults" is just some extra options. "errors=recover" tries to recover/fix the partition if any errors occur when trying to mount, "defaults" allows a non-root user to read/write to the drive. Read the man page to find out more about those: "man mount"
    Last edited by platinummonkey; June 20th, 2007 at 03:53 AM.

  5. #1755
    Join Date
    Mar 2007
    Location
    Greensboro, NC, USA
    Beans
    71
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Thanks again, platinummonkey...

    I read through the manual found in man mount, and, well, it didn't make a whole lot of sense to this newbie. Using your advice, here is my terminal output:

    atm@atm-laptop:~$ sudo mount -t ntfs-3g /dev/sda /media/western_digital -o errors=recover defaults
    Password:
    Usage: mount -V : print version
    mount -h : print this help
    mount : list mounted filesystems
    mount -l : idem, including volume labels
    So far the informational part. Next the mounting.
    The command is `mount [-t fstype] something somewhere'.
    Details found in /etc/fstab may be omitted.
    mount -a [-t|-O] ... : mount all stuff from /etc/fstab
    mount device : mount device at the known place
    mount directory : mount known device here
    mount -t type dev dir : ordinary mount command
    Note that one does not really mount a device, one mounts
    a filesystem (of the given type) found on the device.
    One can also mount an already visible directory tree elsewhere:
    mount --bind olddir newdir
    or move a subtree:
    mount --move olddir newdir
    A device can be given by name, say /dev/hda1 or /dev/cdrom,
    or by label, using -L label or by uuid, using -U uuid .
    Other options: [-nfFrsvw] [-o options] [-p passwdfd].
    For many more details, say man 8 mount .
    In your opinion, should I try the "mount," "mount device," or "mount directory" command?

    Thanks again!

  6. #1756

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    hmm, well, after reading ntfs-3g man page, it seems the errors option is not listed, so it may not be supported. use this instead:
    Code:
    sudo mount -t ntfs-3g /dev/sda /media/western_digital -o defaults
    if that fails, This is kinda risky, but try adding "force" right after defaults. This will force a mount even if there are errors on the drive. this will clean the logfile, but if something goes awry, that would be really bad...(you might loose everything on the partition so be warned when using the force option!)

    btw, we are using the mount device option. simply putting mount lists all the mounted devices on your system, mount -a remounts all the devices on your system without restart, and mount directory can be used to rename or move the mount location of a device but note, only "mount" and "mount -a" from what i just said are actual commands. "mount device" "mount directory" are used to describe the kind of mount, trying to use those two commands in the terminal will result in an error
    Last edited by platinummonkey; June 20th, 2007 at 05:11 AM.

  7. #1757
    Join Date
    Mar 2007
    Location
    Greensboro, NC, USA
    Beans
    71
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Okay, thanks very much (again)!

    I have all (or at least 97%) of my files backed up on DVDs, so this is a risk I'm willing to take. I will try it out and report back. Cheers!

  8. #1758
    Join Date
    Mar 2007
    Location
    Greensboro, NC, USA
    Beans
    71
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Well, it was a no-go. Here's my terminal output:

    atm@atm-laptop:~$ sudo mount -t ntfs-3g /dev/sda1 /media/western_digital -o defaults
    $LogFile indicates unclean shutdown (0, 0)
    Failed to mount '/dev/sda1': Operation not supported
    Mount is denied because NTFS logfile is unclean. Choose one action:
    Boot Windows and shutdown it cleanly, or if you have a removable
    device then click the 'Safely Remove Hardware' icon in the Windows
    taskbar notification area before disconnecting it.
    Or
    Run 'ntfsfix' on Linux unless you have Vista, then mount NTFS with
    the 'force' option read-write, or with the 'ro' option read-only.
    Or
    Mount the NTFS volume with the 'ro' option in read-only mode.
    atm@atm-laptop:~$ sudo mount -t ntfs-3g /dev/sda1 /media/western_digital -o defaults force
    Usage: mount -V : print version
    mount -h : print this help
    mount : list mounted filesystems
    mount -l : idem, including volume labels
    So far the informational part. Next the mounting.
    The command is `mount [-t fstype] something somewhere'.
    Details found in /etc/fstab may be omitted.
    mount -a [-t|-O] ... : mount all stuff from /etc/fstab
    mount device : mount device at the known place
    mount directory : mount known device here
    mount -t type dev dir : ordinary mount command
    Note that one does not really mount a device, one mounts
    a filesystem (of the given type) found on the device.
    One can also mount an already visible directory tree elsewhere:
    mount --bind olddir newdir
    or move a subtree:
    mount --move olddir newdir
    A device can be given by name, say /dev/hda1 or /dev/cdrom,
    or by label, using -L label or by uuid, using -U uuid .
    Other options: [-nfFrsvw] [-o options] [-p passwdfd].
    For many more details, say man 8 mount .
    atm@atm-laptop:~$ mount device
    mount: can't find device in /etc/fstab or /etc/mtab
    atm@atm-laptop:~$ mount -a
    mount: only root can do that
    atm@atm-laptop:~$ sudo mount -a
    $LogFile indicates unclean shutdown (0, 0)
    Failed to mount '/dev/sda1': Operation not supported
    Mount is denied because NTFS logfile is unclean. Choose one action:
    Boot Windows and shutdown it cleanly, or if you have a removable
    device then click the 'Safely Remove Hardware' icon in the Windows
    taskbar notification area before disconnecting it.
    Or
    Run 'ntfsfix' on Linux unless you have Vista, then mount NTFS with
    the 'force' option read-write, or with the 'ro' option read-only.
    Or
    Mount the NTFS volume with the 'ro' option in read-only mode.
    atm@atm-laptop:~$
    Any ideas? Thanks again in advance!

  9. #1759
    Join Date
    Jun 2007
    Beans
    6

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Quote Originally Posted by platinummonkey View Post
    @mimiba - question...if your hbd..1 is just your xp system os, then why do you need to mount it?
    also, you could try this command to mount since i noticed there are non-english characters in your output..
    Code:
    sudo mount -t ntfs-3g /dev/mapper/nvidia_hbdhjhac1 /media/Windows -o locale=hu_HU.utf8
    this makes filenames with non-english characters visible and might be your problem. of course that is assuming from your output that there are non-english character filenames.
    Thanks for your answer, but what you said to do seemed to be a hard work!
    How could I use fdisk win98 boot disk to repartition logical disk without distroy Linux & swap. It's raid 0 system!!

    By the way, do you think it is easier that I change the /dev/mapper/nvidia_hbdhjhac5 partition (NTFS partition that store data) to FAT32 partition? could Ubuntu recognize that raid 0 FAT32 partion with any difficulty?
    Last edited by mimiba; June 20th, 2007 at 06:40 AM.

  10. #1760
    Join Date
    Jun 2007
    Beans
    6

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Quote Originally Posted by szaka View Post
    You weren't mounting with ntfs-3g but with the kernel NTFS driver. Change the 'ntfs' file system type to 'ntfs-3g' in your fstab.
    Also thanks for your answer
    I also use ntfs-3g in my fstab, not ntfs...

Page 176 of 203 FirstFirst ... 76126166174175176177178186 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •