I just spend the last hour and fifteen minutes trying to solve a particular problem on a friend's HP desktop PC running Microsoft Windows 7 Home Premium Service Pack 1 64 bit and it still isn't solved. He's got an older Nvidia GeForce GT 220 GPU and I couldn't update to the latest 320.49 WHQL drivers so I mistakenly uninstalled the old drivers. Now, I can't get the old one to re-install correctly. I did a search and it seems like I have to remove a RAM module and boot into safe mode and uninstall all graphics drivers and boot back into regular mode to install the new graphics drivers and then test it if it works. Then, I have to put the RAM module back in to make sure everything works.

This is bs.

I don't get these problems with Ubuntu. Then again, I'm using the open source Intel drivers and everything works perfectly. Ubuntu works just fine as it did before. Ubuntu 12.04.3 LTS 64 bit is particularly stable.

I had another friend who has a retina MacBook Pro and she is having problems updating her Nvidia graphics drivers to the latest version. I finally figured it out where I had to remove the old one and install the new one, but it worked.

I think that given the difficulties with Microsoft Windows, I'm going to stay far away from it as much as possible. It's too painful to get software and device drivers to update correctly without going through major problems.

My first friend has a bunch of outdated device drivers that need to be updated, but nothing is working. I think he has to do a system recovery back to the factory default configuration which means that he'll lose everything because he doesn't backup his data.

My other friend can't re-install Super Anti-Spyware Professional. The installer won't work and his Windows 7 installation is partially corrupted. He has to do a system recovery again for the fourth time in less than 6 months.

These aren't techies that I'm talking about or else they would do it themselves. I thought Windows 7 was supposed to be the greatest operating system that Microsoft ever released, but I guess it isn't.

Ubuntu gives me none of this bs. It just works.