Results 1 to 3 of 3

Thread: Install grub2 from livecd on gpt efi

  1. #1
    Join Date
    Aug 2013
    Beans
    3

    Question Install grub2 from livecd on gpt efi

    Hi

    I would like to install clear grub2 on efi partition.

    I mounted the partitions of efi on /mnt

    Code:
     ls /mnt/EFI/
    Boot/      Microsoft/ redhat/
    I began installations grub

    Code:
    grub-install --target=x86_64-efi --efi-directory=/mnt/EFI/ --bootloader-id=grub2 --recheck --debug
    source_dir doesn't exist. Please specify --target or --directory
    Can someone help me with the manual installation of grub2 on the board efi and gpt?

  2. #2
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Install grub2 from livecd on gpt efi

    Not sure what you are trying to do?

    Manually create efi on flash drive which is similar to any efi partition. You would have to edit your grub.cfg yourself.
    http://ubuntuforums.org/showthread.p...5#post12599515
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    Aug 2013
    Beans
    3

    Re: Install grub2 from livecd on gpt efi

    Maybe not the best place for publications

    The operating system on the disk: RedHat, Windows 7

    How to install grub on a purely

    In my case, it came to damage EFI bootloader. I run Ubuntu live from the cd-rom. Please remember to boot ubuntu with UEFI mode. I succeeded only after the live usb pendrive.

    Once booted, I logged onto the console in root mode.

    Code:
    sudo su -
    Then I mounted the partitions of / RH and mounted the proc, sys, dev,efi into RH
    Code:
    mount /dev/sda5 /mnt 
    mount -o bind /proc /mnt/proc
    mount -o bind /sys /mnt/sys
    mount -o bind /dev /mnt/dev
    mount /dev/sda1 /mnt/boot/efi
    chroot /mnt
    I downloaded the new version of grub2 and installed it

    Code:
    wget ftp://ftp.gnu.org/gnu/grub/grub-2.00.tar.gz
    tar  -xvf ./grub-2.00.tar.gz
    yum install bison flex
      
       
     ./configure --with-platform=efi --enable-grub-fstest=no   --enable-grub-mkfont=no --disable-nls --enable-efiemu=no
    make -j 8
    make  install
    I proceeded to restore the bootloader
    Code:
    grub-mkstandalone --directory="/usr/local/lib/grub/x86_64-efi/"  --format="x86_64-efi" --output="/boot/efi/EFI/ubuntu/grubx64.efi" 
      
     "boot/grub/grub.cfg"
    grub-install --bootloader-id ubuntu /dev/sda  --target /boot/efi/EFI/ubuntu --directory=/usr/local/lib/grub/x86_64-efi/
    Then you need to check the UEFI settings
    Code:
    efibootmgr -v
    If you get an error message about the absence of the module check whether the system is surely UEFI boot mode


    To delete the INVALID entries do
    Code:
    efibootmgr -b 000x -B 000x
    To add a again bootloader from Windows
    Code:
    efibootmgr -c -L "Windows 7" -l \\EFI\\Microsoft\\Boot\\bootmgfw.efi
    To add Grub
    Code:
    efibootmgr -c -L "Grub2" -l \\EFI\\ubuntu\\grubx64.efi
    Sorry for my English

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •