Results 1 to 3 of 3

Thread: Video settings messed up after update

  1. #1
    Join Date
    Aug 2009

    Video settings messed up after update

    I have been running 12.04 for a number of years now without any issues, using the update manager whenever it showed that there were updates. Recently, I ran update manager and it took forever to run. It appeared to be updating/installing nvidia-304 although I already had 319 installed. After the update, it requested a reboot, after which I was presented with a command line screen. I have tried purging nvidia packages uusing "sudo apt-get purge nvidia*" and then rebooting. This gives me back a graphical display, but there is no nvidia installed so I can't use nvidia-settings to change the resolution. Every time I use some of the suggestions from this forum to re-install nvidia drivers, I end up with the text-only command line screen again. HELP!!!

  2. #2
    Join Date
    Feb 2009
    Dallas, TX
    Ubuntu 16.04 Xenial Xerus

    Re: Video settings messed up after update

    Hi mbongiov.

    I just recover my laptop from the same situation.

    These are the steps I took in text mode:
    • Get the list of Nvidia packages currently installed:
      dpkg -l  | grep nvidia
    • Star purging the nvidia-* packages using this structure:
      sudo apt-get purge nvidia-304
    • Remove all packages separately except for these two:
    • Then reconfigure nvidia common:
      sudo dpkg-reconfigure nvidia-common
    • At this point you can reboot, and you'll be using by default the Open Source driver (nouveau).
    • Go to 'Additional drivers' and reinstall the recommend Nvidia driver from there.
    • When finish, create a new X conf file:
      sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old
      sudo nvidia-xconfig

    Now restart so that the Nvidia driver can take effect.

    Hope it helps. Let us know how it goes.
    Last edited by papibe; August 23rd, 2013 at 02:41 AM.

  3. #3
    Join Date
    Aug 2009

    Re: Video settings messed up after update

    Sorry, but that didn't help. I just ended up re-installing Ubuntu and now all is well.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts