Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: Broken Packages - need to figure out which

  1. #21
    Join Date
    Oct 2012
    Beans
    15

    Re: Broken Packages - need to figure out which

    Quote Originally Posted by ibjsb4 View Post
    I would like to see if any of the other PPAs are conflicting with gnome3 ppa.

    Open your software sources and UNcheck all PPAs except gnome3-team-gnome3 and then do another update.
    Update what?

    Quote Originally Posted by Jonathan Precise View Post
    The GNOME 3.8 PPA can break some packages (I tried it myself, broke Ubuntu-Tweak and some other packages). Try:

    Code:
    sudo apt-get install ppa-purge
    ppa-purge ppa:gnome3-team/gnome3
    In the last command, make sure you see which packages are going to be removed before you press Y (packages that should NOT be removed are stuff like 'ubuntu-desktop', 'ubuntu-branding', 'ubuntu-minimal', 'firefox', and others)!!!

    Edit: make sure you enable the gnome-3 ppa before running ppa-purge.

    @bapoumba: No, 'ubuntu-gnome-desktop' should not be on a standard ubuntu raring. 'ubuntu-desktop', 'ubuntu-branding' and 'ubuntu-minimal' should though.
    The following packages have unmet dependencies:
    ppa-purge : Depends: aptitude (>= 0.6.6-1ubuntu1.2) but it is not installable
    E: Unable to correct problems, you have held broken packages.

    I'm about to just give up and reinstall Ubuntu for the 3rd time...

  2. #22
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Broken Packages - need to figure out which

    Quote Originally Posted by Jonathan Precise View Post
    @bapoumba: No, 'ubuntu-gnome-desktop' should not be on a standard ubuntu raring. 'ubuntu-desktop', 'ubuntu-branding' and 'ubuntu-minimal' should though.
    Hmm, ok, just fresh installed 2 weeks ago, and have not changed much except adding some applications I'm used to (KeepassX, dropbox, xchat and such). I'm not sure with which one it came from. But you are correct (I'm not impliying I ever had a doubt )
    http://releases.ubuntu.com/raring/ub...-i386.manifest
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |
    [SIGPIC][/SIGPIC]

  3. #23
    Join Date
    Jun 2013
    Location
    Somewhere on Earth.
    Beans
    516
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Broken Packages - need to figure out which

    Disable the Gnome 3 PPA. Then run:

    Code:
    sudo apt-get update
    sudo apt-get install ppa-purge
    Enable the PPA again, then run:

    Code:
    ppa-purge ppa:gnome3-team/gnome3
    sudo apt-get update
    sudo apt-get install ubuntu-gnome-desktop
    -Jonathan
    Status: CELEBRATING 2016!!! (Offline )

  4. #24
    Join Date
    Oct 2012
    Beans
    15

    Re: Broken Packages - need to figure out which

    Quote Originally Posted by Jonathan Precise View Post
    Disable the Gnome 3 PPA. Then run:

    Code:
    sudo apt-get update
    sudo apt-get install ppa-purge
    Enable the PPA again, then run:

    Code:
    ppa-purge ppa:gnome3-team/gnome3
    sudo apt-get update
    sudo apt-get install ubuntu-gnome-desktop
    Still can't install ppa-purge even with all PPAs disabled.

    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:


    The following packages have unmet dependencies:
    ppa-purge : Depends: aptitude (>= 0.6.6-1ubuntu1.2) but it is not installable
    E: Unable to correct problems, you have held broken packages.

  5. #25
    Join Date
    Jun 2013
    Location
    Somewhere on Earth.
    Beans
    516
    Distro
    Ubuntu 14.04 Trusty Tahr

    Arrow Re: Broken Packages - need to figure out which

    Next time, post the result in code tags:
    (CODE)Put your results here.(/CODE)

    Replace the parenthesis with brackets to get:
    Code:
    Put your results here.
    As for ppa-purge, try:

    Code:
    sudo apt-get install aptitude ppa-purge
    That should fix the problem.
    -Jonathan
    Status: CELEBRATING 2016!!! (Offline )

  6. #26
    Join Date
    Oct 2012
    Beans
    15

    Re: Broken Packages - need to figure out which

    Quote Originally Posted by Jonathan Precise View Post
    Next time, post the result in code tags:
    (CODE)Put your results here.(/CODE)

    Replace the parenthesis with brackets to get:
    Code:
    Put your results here.
    As for ppa-purge, try:

    Code:
    sudo apt-get install aptitude ppa-purge
    That should fix the problem.
    I didn't because it wasn't very long, but OK.

    Code:
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    
    The following packages have unmet dependencies:
     aptitude:i386 : Depends: aptitude-common:i386 (= 0.6.8.1-2ubuntu2) but it is not installable
                     Depends: libept1.4.12:i386 (>= 1.0.9) but it is not going to be installed
                     Depends: libxapian22:i386 but it is not going to be installed
                     Recommends: apt-xapian-index:i386 but it is not installable
                     Recommends: libparse-debianchangelog-perl:i386 but it is not installable
    E: Unable to correct problems, you have held broken packages.
    tyteen4a03@T4-PC:~$ sudo apt-get install aptitude-common
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Package aptitude-common:i386 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    
    
    E: Package 'aptitude-common:i386' has no installation candidate
    tyteen4a03@T4-PC:~$

  7. #27
    Join Date
    Jun 2013
    Location
    Somewhere on Earth.
    Beans
    516
    Distro
    Ubuntu 14.04 Trusty Tahr

    Exclamation Re: Broken Packages - need to figure out which

    Quote Originally Posted by tyteen4a03 View Post
    I didn't because it wasn't very long, but OK.

    Code:
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    
    The following packages have unmet dependencies:
     aptitude:i386 : Depends: aptitude-common:i386 (= 0.6.8.1-2ubuntu2) but it is not installable
                     Depends: libept1.4.12:i386 (>= 1.0.9) but it is not going to be installed
                     Depends: libxapian22:i386 but it is not going to be installed
                     Recommends: apt-xapian-index:i386 but it is not installable
                     Recommends: libparse-debianchangelog-perl:i386 but it is not installable
    E: Unable to correct problems, you have held broken packages.
    tyteen4a03@T4-PC:~$ sudo apt-get install aptitude-common
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Package aptitude-common:i386 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    
    
    E: Package 'aptitude-common:i386' has no installation candidate
    tyteen4a03@T4-PC:~$
    Oh my! This may be serious!!!

    Try:
    Code:
    gksu gedit /etc/apt/sources.list
    Change:

    Code:
    ... mirror.the-name-of-your-mirror.net/ubuntu raring ...
    to:

    Code:
    ... us.archive.ubuntu.com/ubuntu raring ...
    I have had personal experiences that mirrors do not contain every package.

    Then try:

    Code:
    sudo apt-get update; sudo apt-get install aptitude-common aptitude ppa-purge
    That should fix the problem.
    Last edited by Jonathan Precise; August 31st, 2013 at 11:39 PM. Reason: Added "Update package lists..."
    -Jonathan
    Status: CELEBRATING 2016!!! (Offline )

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •