Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: How do I turn off Shotwell autostart?

  1. #1
    Join Date
    Jun 2008
    Location
    Across The Pond
    Beans
    885
    Distro
    Xubuntu 16.04 Xenial Xerus

    How do I turn off Shotwell autostart?

    Shotwell does not play nice with my Kodak Easyshare; or rather my Kodak Easyshare does not play nice with Linux. I finally found some workarounds to get photos transferred to my computer, but not with Shotwell (Shotwell was part of the problem). At one time I thought I found where I could choose to not let Shotwell automatically start when I mounted the camera or SD card reader. I cannot find this any more; it's not under Shotwell preferences, nor Preferred Applications. Does anyone know how I can turn off Shotwell autostart?
    "Everybody is ignorant, only on different subjects." Will Rogers

  2. #2
    Join Date
    Mar 2010
    Beans
    Hidden!

  3. #3
    Join Date
    Jun 2008
    Location
    Across The Pond
    Beans
    885
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: How do I turn off Shotwell autostart?

    d2btoo, thanks for the response. Both links gave me a start. My menus are slightly different, but I can get to "Removable Drives and Media." However, nothing addresses Shotwell, nor any photo management tool. Curious, yes?
    "Everybody is ignorant, only on different subjects." Will Rogers

  4. #4
    Join Date
    Mar 2010
    Beans
    Hidden!

    Re: How do I turn off Shotwell autostart?

    Yeah, that's the trouble... menus are all different across different versions and DE's.
    For example, I'm at the moment in my desktop which runs old Lucid, so I can't check for now for the "new menus of current versions". Anyway if it helps, I think you need to make sure to double check the setting which controls what happens when you put removable media -- either make it ask you or completely disable it.

    here is a screen shot of it (but this is old Lucid way )
    http://i.imm.io/1fAZg.png
    Last edited by d2btoo; August 20th, 2013 at 03:38 PM. Reason: put the screen shot

  5. #5
    Join Date
    Jun 2008
    Location
    Across The Pond
    Beans
    885
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: How do I turn off Shotwell autostart?

    Lucid was one of my favorites. Now, I don't even have a media tab!

    I've unchecked "browse removable media when inserted" under storage in removable drives and media, but that doesn't effect Shotwell's behavior. Under camera, the only option is "import digital photographs when connected," but that's not even checked. Seems like somebody didn't realize not everyone would want Shotwell!
    "Everybody is ignorant, only on different subjects." Will Rogers

  6. #6
    Join Date
    Jun 2008
    Location
    Across The Pond
    Beans
    885
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: How do I turn off Shotwell autostart?

    From the Shotwell help files

    Shotwell may also be executed automatically when a camera is plugged in to your computer. To check that your system is set up to run Shotwell when a camera is detected, go to Edit ▸ Preferences in any Nautilus (file browser) window and choose the Media tab. You'll see a dropdown box entitled Photos: which lets you choose Shotwell as your photo handling application.
    I'm running Xfce on Ubuntu but can still access Nautilus. In Ubuntu 12.04, Nautilus no longer has a media tab. The help file is outdated.

    So where has photo handling preferences been moved to????
    "Everybody is ignorant, only on different subjects." Will Rogers

  7. #7
    Join Date
    Dec 2008
    Location
    UK
    Beans
    434
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: How do I turn off Shotwell autostart?

    Does this thread help:

    http://ubuntuforums.org/showthread.php?t=1976683

    In xfce you find this also under Settings | Settings Manager | Removable Drives and Media

  8. #8
    Join Date
    Mar 2010
    Beans
    Hidden!

    Re: How do I turn off Shotwell autostart?

    Please see here http://askubuntu.com/questions/22313...ow-do-i-use-it and here http://askubuntu.com/questions/69606...-usb-auto-play (not the chosen answer but the answer below it)

    So basically check out if you find any interesting property regarding shotwell with the dconf and gsettings, if not then try to disable autorun altogether!


    oops! didn't see Azdour's post! Please disregard this post.
    Last edited by d2btoo; August 20th, 2013 at 04:43 PM.

  9. #9
    Join Date
    Jun 2008
    Location
    Across The Pond
    Beans
    885
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: How do I turn off Shotwell autostart?

    @ Azdour, thanks. I've found Removable Drives and Media, but there are no options to address this. I've unchecked everything except to mount removable media when inserted. Everything else is disabled.

    @ d2btoo, I will check those out! I never think to look at Ask Ubuntu, unless it comes up in a search. However, this may put me on the right track.
    "Everybody is ignorant, only on different subjects." Will Rogers

  10. #10
    Join Date
    Dec 2008
    Location
    UK
    Beans
    434
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: How do I turn off Shotwell autostart?

    @d2btoo - you didn't need to edit out your post my solution did not work so maybe yours will. that's why sometimes posting various solutions helps the OP

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •