@ Shobuz99;

gnome-terminal-data
Depends: gconf2
does not seem to help us much in finding out why "gnome-terminal-data" does not want to install ... but let's look at the state anyway:
Code:
apt-cache policy gconf2
dpkg -l gconf2
There is a reason ... I just do not see it at this time !. Are we to the point to try and (un-)install it --see what errors we get (??) and then try and (re-)install "gnome-terminal-data 2.30.2-0ubuntu1" // Is my syntax invalid; if we attempt to install as " gnome-terminal-data-2.30.20ubuntu1" ???
(note the added dash preceding the 2 in the version ...maybe I best do some home work ...grasping at straws for howcome why !

@ bapoumba ;
as Shobuz99 has related;
We had that "`openjdk-6-jre-headless'" snake stomped out at one point .. do not know why it has come back to bite us ! As well as "`icedtea-6-jre-cacao'" ..

off to do homework !