Results 1 to 7 of 7

Thread: got error while trying to compile vlc2.0.0 using make command

  1. #1
    Join Date
    May 2013
    Beans
    51

    got error while trying to compile vlc2.0.0 using make command

    Hi friends,

    I installed the vlc2.0.0 source code from the url: http://download.videolan.org/vlc/2.0.0/
    While compiling it using make command, I got the following error:

    Making all in share
    make[2]: Entering directory `/home/rahul/Gstreamer/vlc-2.0.0/share'
    LUAC lua/playlist/appletrailers.luac
    /usr/local/bin/luac: lua/playlist/appletrailers.lua:70: invalid escape sequence near '\.'
    make[2]: *** [lua/playlist/appletrailers.luac] Error 1
    make[2]: Leaving directory `/home/rahul/Gstreamer/vlc-2.0.0/share'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/rahul/Gstreamer/vlc-2.0.0'
    make: *** [all] Error 2


    I checked further for lua, which was installed in my system
    rahul@rahul-VPCEG28FN:~$ lua -v
    Lua 5.2.2 Copyright (C) 1994-2013 Lua.org, PUC-Rio

    I even installed liblua5.2-dev package by using "Synaptic Package manager", but was not able to remove my error.

    Please someone tell me what shoul I do?

    Thanks & Regards

  2. #2
    Join Date
    Jan 2009
    Location
    ::1
    Beans
    2,485

    Re: got error while trying to compile vlc2.0.0 using make command

    I would start by using the most recent VLC: http://download.videolan.org/vlc/last/

  3. #3
    Join Date
    May 2013
    Beans
    51

    Re: got error while trying to compile vlc2.0.0 using make command

    @sanderj:

    I did the same but gor error whulr execution:

    rahul@rahul-VPCEG28FN:~$ vlc ABC.webm
    VLC media player 2.0.5 Twoflower (revision 2.0.5-0-g1661b7d)
    [0x9273908] main libvlc error: No plugins found! Check your VLC installation.



    Please tell me how to resolvde it..

  4. #4
    Join Date
    Jan 2009
    Location
    ::1
    Beans
    2,485

    Re: got error while trying to compile vlc2.0.0 using make command

    why do you want to compile VLC yourself? Why not install it using "sudo apt-get install vlc"?

  5. #5
    Join Date
    Aug 2013
    Beans
    9

    Re: got error while trying to compile vlc2.0.0 using make command

    Quote Originally Posted by sanderj View Post
    why do you want to compile VLC yourself? Why not install it using "sudo apt-get install vlc"?
    People always answer these type of threads by saying something like this. I think the answer is, "because we can".

    Personally, I've learned a lot about the system by compiling things for some crazy reason and then trying to fix dependency errors or whatnot. Granted, the most important lesson was that the package manager is there for a reason, but it was fun at the time. And there's always the odd package that wasn't compiled with some option that I want. I think on an old Debian or something GtkPod wasn't compiled with mp3 support for licensing reasons so I compiled it myself. It happens.
    Last edited by nathan-b; August 12th, 2013 at 04:35 AM.

  6. #6
    Join Date
    Nov 2005
    Location
    Bordeaux, France
    Beans
    11,292
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: got error while trying to compile vlc2.0.0 using make command

    Quote Originally Posted by nathan-b View Post
    People always answer these type of threads by saying something like this. I think the answer is, "because we can".
    Well, this OP obviously can't.
    「明後日の夕方には帰ってるからね。」


  7. #7
    Join Date
    Aug 2011
    Location
    47°9′S 126°43W
    Beans
    2,165
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: got error while trying to compile vlc2.0.0 using make command

    Have you at least got a look at line 70 of lua/playlist/appletrailers.lua?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •