Results 1 to 3 of 3

Thread: Key mapping suddenly changed

  1. #1
    Join Date
    Aug 2013

    Key mapping suddenly changed

    Hello, I have a problem with my laptop keybord. My key mapping suddenly changed, keys like ctrl, insert, delete etc. switched places along with all Fn associated keys like numeric keyboard (num lock completely disappeared), brightness and volume controls (they are now functioning with ctrl+arrows if that is any help). Is there a way to somehow restore mapping to original factory settings? I have not messed with any system settings, but there were a lot of updates before this happened and I had to disconnect the keyboard to clean dust from laptop fan, I'm not sure if it can be related, just giving you all the info I can think of.

    Here's a list of updates that were installed before this happened, sorry it is this long. I would appreciate any help in this. Thanks

    I use Xubuntu 12.04

    Start-Date: 2013-08-01 15:06:59
    Commandline: aptdaemon role='role-upgrade-system' sender=':1.54'
    Upgrade: libebackend-1.2-1:amd64 (3.2.3-0ubuntu7, 3.2.3-0ubuntu7.1),
    bind9-host:amd64 (9.8.1.dfsg.P1-4ubuntu0.6, 9.8.1.dfsg.P1-4ubuntu0.7),
    dnsutils:amd64 (9.8.1.dfsg.P1-4ubuntu0.6, 9.8.1.dfsg.P1-4ubuntu0.7),
    liblcms2-2:amd64 (2.2+git20110628-2ubuntu3, 2.2+git20110628-2ubuntu3.1),
    libdns81:amd64 (9.8.1.dfsg.P1-4ubuntu0.6, 9.8.1.dfsg.P1-4ubuntu0.7),
    libedata-book-1.2-11:amd64 (3.2.3-0ubuntu7, 3.2.3-0ubuntu7.1),
    libisccc80:amd64 (9.8.1.dfsg.P1-4ubuntu0.6, 9.8.1.dfsg.P1-4ubuntu0.7),
    libedata-cal-1.2-13:amd64 (3.2.3-0ubuntu7, 3.2.3-0ubuntu7.1),
    linux-firmware:amd64 (1.79.4, 1.79.6),
    liblwres80:amd64 (9.8.1.dfsg.P1-4ubuntu0.6, 9.8.1.dfsg.P1-4ubuntu0.7),
    libedataserver-1.2-15:amd64 (3.2.3-0ubuntu7, 3.2.3-0ubuntu7.1),
    libebook-1.2-12:amd64 (3.2.3-0ubuntu7, 3.2.3-0ubuntu7.1),
    libgcrypt11:amd64 (1.5.0-3ubuntu0.1, 1.5.0-3ubuntu0.2),
    libgcrypt11:i386 (1.5.0-3ubuntu0.1, 1.5.0-3ubuntu0.2),
    libbind9-80:amd64 (9.8.1.dfsg.P1-4ubuntu0.6, 9.8.1.dfsg.P1-4ubuntu0.7),
    libcamel-1.2-29:amd64 (3.2.3-0ubuntu7, 3.2.3-0ubuntu7.1),
    libecal-1.2-10:amd64 (3.2.3-0ubuntu7, 3.2.3-0ubuntu7.1),
    linux-generic-lts-quantal:amd64 (,,
    libisccfg82:amd64 (9.8.1.dfsg.P1-4ubuntu0.6, 9.8.1.dfsg.P1-4ubuntu0.7),
    gpgv:amd64 (1.4.11-3ubuntu2.2, 1.4.11-3ubuntu2.3),
    evolution-data-server-common:amd64 (3.2.3-0ubuntu7, 3.2.3-0ubuntu7.1),
    evolution-data-server:amd64 (3.2.3-0ubuntu7, 3.2.3-0ubuntu7.1),
    linux-libc-dev:amd64 (3.2.0-49.75, 3.2.0-51.77),
    libisc83:amd64 (9.8.1.dfsg.P1-4ubuntu0.6, 9.8.1.dfsg.P1-4ubuntu0.7),
    libedataserverui-3.0-1:amd64 (3.2.3-0ubuntu7, 3.2.3-0ubuntu7.1),
    gnupg:amd64 (1.4.11-3ubuntu2.2, 1.4.11-3ubuntu2.3)
    End-Date: 2013-08-01 15:08:36

    Start-Date: 2013-08-01 19:02:28
    Commandline: aptdaemon role='role-commit-packages' sender=':1.67'
    Install: linux-headers-3.2.0-51:amd64 (3.2.0-51.77),
    linux-headers-3.5.0-37:amd64 (3.5.0-37.58~precise1),
    linux-image-3.5.0-37-generic:amd64 (3.5.0-37.58~precise1),
    linux-headers-3.2.0-51-generic:amd64 (3.2.0-51.77),
    linux-headers-3.5.0-37-generic:amd64 (3.5.0-37.58~precise1)
    Upgrade: linux-image-generic-lts-quantal:amd64 (,,
    linux-headers-generic-lts-quantal:amd64 (,,
    linux-headers-generic:amd64 (,
    End-Date: 2013-08-01 19:04:26

    Start-Date: 2013-08-02 09:51:41
    Commandline: aptdaemon role='role-upgrade-system' sender=':1.48'
    Upgrade: apt-transport-https:amd64(0.8.16~exp12ubuntu10.11,0.8.16~exp12ub untu10.12),
    libgudev-1.0-0:amd64 (175-0ubuntu9.3,175-0ubuntu9.4),
    libevince3-3:amd64 (3.4.0-0ubuntu1.6, 3.4.0-0ubuntu1.7),
    libapt-inst1.4:amd64 (0.8.16~exp12ubuntu10.11, 0.8.16~exp12ubuntu10.12),
    grub-pc:amd64 (1.99-21ubuntu3.9, 1.99-21ubuntu3.10),
    apt-utils:amd64 (0.8.16~exp12ubuntu10.11, 0.8.16~exp12ubuntu10.12),
    udev:amd64 (175-0ubuntu9.3, 175-0ubuntu9.4),
    apt:amd64 (0.8.16~exp12ubuntu10.11, 0.8.16~exp12ubuntu10.12),
    evince-common:amd64 (3.4.0-0ubuntu1.6, 3.4.0-0ubuntu1.7),
    evince:amd64 (3.4.0-0ubuntu1.6, 3.4.0-0ubuntu1.7),
    libapt-pkg4.12:amd64 (0.8.16~exp12ubuntu10.11, 0.8.16~exp12ubuntu10.12),
    grub-pc-bin:amd64 (1.99-21ubuntu3.9, 1.99-21ubuntu3.10),
    gir1.2-gudev-1.0:amd64 (175-0ubuntu9.3, 175-0ubuntu9.4),
    libudev0:amd64 (175-0ubuntu9.3, 175-0ubuntu9.4),
    grub-common:amd64 (1.99-21ubuntu3.9, 1.99-21ubuntu3.10),
    grub2-common:amd64 (1.99-21ubuntu3.9, 1.99-21ubuntu3.10)
    End-Date: 2013-08-02 09:53:42

  2. #2
    Join Date
    May 2008
    Ubuntu 13.04 Raring Ringtail

    Re: Key mapping suddenly changed

    Have you checked what kind of keyboard layout you're actually using? Have a look here if you don't know where to check it.

  3. #3
    Join Date
    Aug 2013

    Re: Key mapping suddenly changed

    Yes, I tried leaving just the "use system defaults" checked, then I tried different keyboard models, but nothing fixed it. I use czech keyboard layout.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts