Results 1 to 3 of 3

Thread: scanning programs suddenly stopped working (12.04)

  1. #1
    Join Date
    Jun 2008

    scanning programs suddenly stopped working (12.04)


    I have recently installed 12.04 and set up, not without difficulties, a scanner (hp scanjet 2400) that I was nicely using with xsane.

    After a recent automatic update of the system, any attempt to scan pictures results in a crash of the scanning program, independently on which program I tried to use (meaning xsane, simplescan, scanner utility, gscan2pdf, skanlite, yes I have tried them all...). The result is always the same, the programs crash.

    After the crash, the bug report pop up points to a problem with the third party

    I have purged and installed from scratch xsane, the sane back-ends, libsane-dev several times, and the problem persists, and I couldn't find any thread that could help me solve this.

    Did anyone experience anything similar or has any suggestions?


  2. #2
    Join Date
    Jun 2009

    Re: scanning programs suddenly stopped working (12.04)

    run scanimage -L
    you will get something like this:
    device `hpaio:/usb/Officejet_4500_G510g-m?serial=CN12JF10VM05CQ' is a Hewlett-Packard Officejet_4500_G510g-m all-in-one
    now run this obviously part of this command comes from part of the output from the last command
    scanimage --help -d hpaio:/usb/Officejet_4500_G510g-m?serial=CN12JF10VM05CQ
    see if it crashes doing that

    Are you sure you are using 12.04 LTS and not 13.10 Alpha? i am running 13.04 and only have version 1.0.23-0ubuntu1 for libsane
    i know 13.10 has a issue with scanimage that makes it crash 30-60% of the time
    12.04 should have libsane version 1.0.22-7ubuntu1 or do you have a ppa enabled for scanimage?
    Laptop: ASUS A54C-NB91 (Storage: WD3200BEKT + MKNSSDCR60GB-DX); Desktop: Custom Build - Images included; rPi Server
    Putting your Networked Printer's scanner software to shame PHP Scanner Server
    I frequently edit my post when I have the last post

  3. #3
    Join Date
    Jun 2008

    Re: scanning programs suddenly stopped working (12.04)

    the Ubuntu version I am using is 12.04, I didn't upgrade to 13.0. libsane are 1.0.24 because I compiled and installed from the sane backends website since with the built in 1.0.22 I didn't manage to get high resolution scans (i.e. 600dpi) with my scanner.

    when I type:
    serena-iMac:~> scanimage -L
    device `v4l:/dev/video0' is a Noname FaceTime HD Camera (Built-in) virtual device
    device `genesys:libusb:001:005' is a Hewlett Packard ScanJet 2400c flatbed scanner
    device `epson2:net:' is a Epson PID 0899 flatbed scanner

    the epson scanner must be a network scanner in some other room because I don't have such device in my room (it's a workplace issue...)

    if I ask:
    serena-iMac:~> scanimage --help -d genesys:libusb:001:005
    Usage: scanimage [OPTION]...

    Start image acquisition on a scanner device and write image data to
    standard output.


    List of available devices:
    v4l:/dev/video0 genesys:libusb:001:005 epson2:net:

    so it seems to see the scanner

    if I type

    serena-iMac:~> scanimage -d genesys:libusb:001:005 --preview=yes --resolution=600 > test
    Segmentation fault (core dumped)

    do you think I should try to change the libsane version?

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts