Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: AppArmor is not working.

  1. #11
    Join Date
    May 2010
    Location
    uk
    Beans
    9,249
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: AppArmor is not working.

    Hi

    Please post the output of

    Code:
    cat /etc/default/grub
    Let's see if those selinux commands have been added to that file.

    I take it this is a non virtualised installation.

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

    Thinking about becoming an Ubuntu Member?

  2. #12
    Join Date
    Aug 2013
    Beans
    16

    Re: AppArmor is not working.

    I have finally solved this problem, AppArmor is all healthy and working without no problems again!

    /proc/cmdline contained:
    BOOT_IMAGE=/boot/vmlinuz-3.2.0-4-686-pae
    root=UUID=26ada0c0-1165-4098-884d-aafd2220c2c6 ro

    Adding "apparmor=1 security=apparmor" to GRUB_CMDLINE_LINUX_DEFAULT in
    /etc/default/grub and running "sudo update-grub" and "sudo reboot" fixed this issue.
    another fix of this problem is:
    $ sudo perl -pi -e 's,GRUB_CMDLINE_LINUX="(.*)"$,GRUB_CMDLINE_LINUX=" $1 apparmor=1 security=apparmor",' /etc/default/grub
    $ sudo update-grub
    $ sudo reboot

    regards,
    koda2

  3. #13
    Join Date
    May 2010
    Location
    uk
    Beans
    9,249
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: AppArmor is not working.

    Hi

    Looking at my kernel configuration...

    Code:
    matthew-S206:/home/matthew % grep -i apparmor /boot/config-3.8.0-27-generic
    CONFIG_SECURITY_APPARMOR=y
    CONFIG_SECURITY_APPARMOR_BOOTPARAM_VALUE=1
    CONFIG_DEFAULT_SECURITY_APPARMOR=y
    CONFIG_DEFAULT_SECURITY="apparmor"
    matthew-S206:/home/matthew %
    ...it looks like apparmor should just work as long as you remove the selinux options from /etc/default/grub.

    There should be no need to add the apparmor options as they should run automatically. You can check your kernel for the same options.

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

    Thinking about becoming an Ubuntu Member?

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •