Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: AppArmor is not working.

  1. #1
    Join Date
    Aug 2013
    Beans
    16

    Cool AppArmor is not working.

    I uninstalled AppArmor a few days ago and installed SELinux, but I uninstalled SELinux because I didn't like it, then I decided to go back to AppArmor.


    I did "sudo apt-get apparmor" and it was installed, now when I do "sudo apparmor_status"

    it gives me this:

    b0x@ubuntu:~$ sudo apparmor_status
    apparmor module is loaded.
    apparmor filesystem is not mounted.
    b0x@ubuntu:~$


    How do I fix this?
    Last edited by koda2; August 1st, 2013 at 02:00 PM.

  2. #2
    Join Date
    Jul 2013
    Beans
    190

    Re: AppArmor is not working.

    Hi,

    try to install the utils
    sudo apt-get install apparmor-utils

    Evtl. it's the matter. We can ask the NSA if we cant solve the problem.

  3. #3
    Join Date
    Aug 2013
    Beans
    16

    Re: AppArmor is not working.

    I downloaded apparmor-utils, and I am still getting the error....

  4. #4
    Join Date
    Aug 2013
    Beans
    16

    Re: AppArmor is not working.

    I tried reinstalling AppArmor to see if this solves the problem, but it hits me back with:

    * Starting AppArmor profiles * AppArmor not available as kernel LSM.
    [fail]
    invoke-rc.d: initscript apparmor, action "start" failed.
    * Reloading AppArmor profiles * AppArmor not available as kernel LSM.
    [fail]
    invoke-rc.d: initscript apparmor, action "reload" failed.

  5. #5
    Join Date
    Aug 2013
    Beans
    16

    Re: AppArmor is not working.

    I'll give you a more info on this problem,
    I'm using ubuntu 13.04 32bit. I installed the selinux just for test. After I restarted the computer selinux started at permissive mode. Then I removed the selinux package. I noticed that when I installed selinux it automatically removed apparmor. So I tried to reinstall apparmor. But I failed with this message:


    • Starting AppArmor profiles
    • AppArmor not available as kernel LSM. [fail] invoke-rc.d: initscript apparmor, action "start" failed.
    • Reloading AppArmor profiles
    • AppArmor not available as kernel LSM. [fail] invoke-rc.d: initscript apparmor, action "reload" failed.

    What can I do now to get apparmor back? Thanks.

  6. #6
    Join Date
    May 2010
    Location
    uk
    Beans
    9,299
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: AppArmor is not working.

    Hi

    Is this a bare metal installation or a virtualised installation ? If virtualised, what virtualisation software are you using ?

    What version of Ubuntu ? what kernel version ?

    Code:
    cat /etc/lsb-release
    uname -a
    This may allow us to see if it's a known bug.

    EDIT: Looks like we cross posted but if you could still answer the questions above.

    Kind regards
    Last edited by matt_symes; August 1st, 2013 at 01:33 PM.
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

    Thinking about becoming an Ubuntu Member?

  7. #7
    Join Date
    Aug 2013
    Beans
    16

    Re: AppArmor is not working.

    cat /etc/lsb-release shows
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=12.04
    DISTRIB_CODENAME=precise
    DISTRIB_DESCRIPTION="Ubuntu 12.04.2 LTS"

    while uname -a shows
    Linux ubuntu 3.2.0-40-generic #32-Ubuntu SMP Mon Mar 25 21:22:10 UTC 2013 i386 GNU/Linux


    I tried called the status of AppArmor, and it shows:


    b0x@ubuntu:/etc/apparmor.d$ sudo /etc/init.d/apparmor status
    * AppArmor not available as kernel LSM.
    ...fail!

  8. #8
    Join Date
    Aug 2013
    Beans
    16

    Re: AppArmor is not working.

    Also tried restarting..


    b0x@ubuntu:/etc/apparmor.d$ sudo /etc/init.d/apparmor restart
    * Reloading AppArmor profiles * AppArmor not available as kernel LSM.
    [fail]

  9. #9
    Join Date
    Aug 2013
    Beans
    16

    Re: AppArmor is not working.

    Another problem:

    I am researching on this problem very closely and I checked /proc/cmdline and it shows:

    b0x@ubuntu:/etc/apparmor.d$ cat /proc/cmdline
    BOOT_IMAGE=/boot/vmlinuz-3.2.0-48-generic-pae root=UUID=[secret key lol] ro quiet splash security=selinux selinux=1 vt.handoff=7

    how do I fix this? I uninstalled SELinux, is there something wrong?

  10. #10
    Join Date
    Jul 2013
    Beans
    190

    Re: AppArmor is not working.

    about the old problem:

    http://manpages.ubuntu.com/manpages/...pparmor.7.html

    there is

    AppArmor supports the Linux kernel's securityfs filesystem, and makes
    available the list of the profiles currently loaded; to mount the
    filesystem:

    # mount -tsecurityfs securityfs /sys/kernel/security
    $ cat /sys/kernel/security/apparmor/profiles
    /usr/bin/mutt
    /usr/bin/gpg

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •