Results 1 to 6 of 6

Thread: cryptswap1 not ready or not present

  1. #1
    Join Date
    Dec 2007
    Location
    Cebu, Philippine
    Beans
    173
    Distro
    Lubuntu 20.04 Focal Fossa

    Question cryptswap1 not ready or not present

    I recently had need to reinstall Ubuntu 12.04, this time encrypting my hard disk. Since then, before the login screen appears, I get the following message:

    The disk drive for /dev/mapper/cryptswap1 is not ready yet or not present.
    Continue to wait or Press S to stop mounting or M for manual recovery.
    If I wait, the log-in screen appears and I log in as normal.

    If I press S, there is a wait and then the log-in screen appears and I log in as normal.

    If I press M, there is a wait and then the log-in screen appears and I log in as normal.

    This happens every time I start my computer.

    Any ideas on what all this means?
    Last edited by rbscairns; July 31st, 2013 at 01:52 PM.

  2. #2
    Join Date
    Sep 2010
    Beans
    898

    Re: cryptswap1 not ready or not present

    I often got that message on 12.04. I found an article about it that said it was a timing issue. I would wait for the message to go away, which only took a few seconds, and the swap partition got mounted properly, so it seemed harmless.

    After booting, you can check whether the swap is mounted correctly:
    Code:
    $ swapon -s
    Filename				Type		Size	Used	Priority
    /dev/mapper/cryptswap1                  partition	2096444	603520	-1

  3. #3
    Join Date
    Dec 2007
    Location
    Cebu, Philippine
    Beans
    173
    Distro
    Lubuntu 20.04 Focal Fossa

    Re: cryptswap1 not ready or not present

    I think you might be right. After logging in, I am getting:
    Code:
    $ swapon -s
    Filename				Type		Size	Used	Priority
    /dev/mapper/cryptswap1                  partition	1038332	9280	-1
    I will do some more research and see if I can make the message not appear.

  4. #4
    Join Date
    Dec 2007
    Location
    Cebu, Philippine
    Beans
    173
    Distro
    Lubuntu 20.04 Focal Fossa

    Re: cryptswap1 not ready or not present

    Here is what I did to stop the message appearing:

    Using
    Code:
    sudo gedit /etc/fstab
    I changed the line
    Code:
    /dev/mapper/cryptswap1 none swap sw 0 0
    to read
    Code:
    /dev/mapper/cryptswap1 none swap sw,noauto 0 0
    I then used
    Code:
    sudo gedit /etc/rc.local
    and immediately before
    Code:
    exit 0
    added these two lines:
    Code:
    sleep 5
    swapon /dev/mapper/cryptswap1
    Upon re-booting, I do not get the message and swapon -s returns:
    Code:
    $ swapon -s
    Filename				Type		Size	Used	Priority
    /dev/mapper/cryptswap1                  partition	1038332	0	-1
    Everything is looking good (I think).
    Last edited by rbscairns; July 31st, 2013 at 01:47 PM.

  5. #5
    Join Date
    Sep 2010
    Beans
    898

    Re: cryptswap1 not ready or not present

    Thanks for posting your solution. I may try it in 12.04, since I noticed that I still get the warning message.

  6. #6
    Join Date
    Nov 2008
    Location
    Piombino (Italy)
    Beans
    Hidden!
    Distro
    Xubuntu 8.04 Hardy Heron

    Re: cryptswap1 not ready or not present

    I use Xubuntu Raring Ringtail 13.04 and I got the same message
    The disk drive for /dev/mapper/cryptswap1 is not ready yet or not present.
    Continue to wait or Press S to stop mounting or M for manual recovery.
    The swap seems to be mounted correctly:
    ~$ swapon -s
    Filename Type Size Used Priority
    /dev/mapper/cryptswap1 partition 1023996 68 -1
    Do you think I can fix the problem like you did?
    Thanks
    Last edited by frupito; August 29th, 2013 at 03:15 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •