Resolved!

Two posts from other forums got me the rest of the way there. First, https://bbs.archlinux.org/viewtopic.php?id=160101]from the Arch forums:

HD 7000 series and newer use glamor for 2D acceleration. Try removing the line containing "EXA" (and other lines beginning with the word "Option" as they might conflict with glamor, once you get everything working, then, if you really need those options, you can try adding them back, apart from "AccelMethod" "EXA" that is) from your 20-radeon.conf and adding those described in the wiki under the glamor section.
I snagged the xorg.conf snippet that followed in the next message. That got this message into my Xorg log: Failed to load module "glamoregl" (module does not exist, 0)

That led me to this thread on Phoronix, which indicated that there was actually an additional driver package, xserver-xorg-video-glamor, that would need to be installed.

After installing that package and rebooting, DRI enabled.

Thanks Temüjin for the help that got me halfway there.