Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Replaced admin user, and now settings prompt for "root" password rather than user's

  1. #1
    Join Date
    Feb 2008
    Location
    in the Ether
    Beans
    31
    Distro
    Ubuntu 13.04 Raring Ringtail

    Post Replaced admin user, and now settings prompt for "root" password rather than user's

    Hi all,

    I recently wanted to encrypt my home folder so set up a new admin user, with an encrypted home, transferred files across from the old user, then deleted the old user. However going to a system settings that requires root (e.g. Software and Updates) now prompt for "root"'s password rather than the new (or old) user's password. The new user is definately in the sudo group and can run sudo commands in the terminal.

    I realise that I could set the password for root (https://help.ubuntu.com/community/RootSudo), but it seems there should be a better way. Is there a config file somewhere that set something like a default admin user?

    Thanks,
    Phil

  2. #2
    Join Date
    Apr 2012
    Beans
    7,064

    Re: Replaced admin user, and now settings prompt for "root" password rather than user

    I'm guessing here but try running

    Code:
    gksu-properties
    from a terminal in the new account and making sure the mode is set to 'sudo' not 'su'

  3. #3
    Join Date
    Feb 2008
    Location
    in the Ether
    Beans
    31
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Replaced admin user, and now settings prompt for "root" password rather than user

    Quote Originally Posted by steeldriver View Post
    from a terminal in the new account and making sure the mode is set to 'sudo' not 'su'
    Thanks, but authentication mode is already set to sudo.

  4. #4
    Join Date
    May 2009
    Location
    Indiana
    Beans
    1,965
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Replaced admin user, and now settings prompt for "root" password rather than user

    How did you go about adding this new admin user? When you open User Accounts and click on that user, does it show Account Type as Administrator or Standard?

    Sorry if these seem like dumb questions, but it is possible to add a user to the sudoers list without making that user a part of the admin group. I suspect that would result in behavior like what you're experiencing. That's the only reason I ask.
    Jane, stop this crazy thing!

  5. #5
    Join Date
    Feb 2008
    Location
    in the Ether
    Beans
    31
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Replaced admin user, and now settings prompt for "root" password rather than user

    @newb85 : don't worry, it's normally a "dumb" question that finds the problem!

    I can confirm the new user is an admin as well as being in the sudo group.

  6. #6
    Join Date
    Mar 2009
    Location
    UK PLC
    Beans
    495
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Replaced admin user, and now settings prompt for "root" password rather than user

    I think the behaviour you are after can be achieved as follows

    open a terminal (How often is this said??)

    type:

    Code:
    sudo visudo
    look for the following line and copy it to the line below (replacing root with the username you want to have sudo access

    Code:
    root    ALL=(ALL:ALL) ALL
    I did this to daughters debian install and it worked a treat - no admin access but she could install certain software! Anything major expected the admin (root) password.

    HTH
    I have a major malfunction!

  7. #7
    Join Date
    Mar 2009
    Location
    UK PLC
    Beans
    495
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Replaced admin user, and now settings prompt for "root" password rather than user

    I think you can also add

    gnome-system-tools

    This will give you back the old familiar 'Users and Groups' gui.
    I have a major malfunction!

  8. #8
    Join Date
    Feb 2008
    Location
    in the Ether
    Beans
    31
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Replaced admin user, and now settings prompt for "root" password rather than user

    I'm in the sudoer list through the sudo group:
    Code:
    %sudo ALL=(ALL:ALL) ALL
    Adding myself as a seperate line doesn't seem to fix the problem either.

    Think I might need to file an ubuntu bug

  9. #9
    Join Date
    Sep 2010
    Beans
    898

    Re: Replaced admin user, and now settings prompt for "root" password rather than user

    I'm not sure if this is a factor, but is it possible that you inadvertantly enabled root login?

    You can determine that by looking at root's entry in /etc/shadow, to see whether the second field is "!" (disabled) or a password hash (enabled).

    If root login is enabled, you can disable it (recommended) using these instructions: https://help.ubuntu.com/community/Ro...r_root_account

  10. #10
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,282
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Replaced admin user, and now settings prompt for "root" password rather than user

    can you show us the following output please?
    Code:
    cat /etc/group

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •