Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Dell WiFi not working in clean 12.04 LTS

  1. #1
    Join Date
    Jul 2013
    Beans
    13

    Dell WiFi not working in clean 12.04 LTS

    My Dell Inspiron 3421 came pre-installed with Ubuntu 12.04 LTS.
    Everything was working including WiFi and Bluetooth.
    Then I made a clean install of Ubuntu 12.04 64bit version.
    And to my surprise, WiFi was not working. However Bluetooth was working.


    Network properties shows the device as 'UNCLAIMED'. And I can't even enable it using 'eth1 up' command.
    I searched through the forums and tried few tricks which were marked as SOLVED, but they didn't work for me.
    and it is not work on Windows 7 64 bit too , i tried download from dell website , after installed it have no respone at all it show a question mark in the device manager

    Device: Dell Wireless 1704 802.11b/g/n (2.4GHz)
    Manufacturer: Atheros AR9485


    This system is of my daily use and really need the WiFi to work. Please help me with solutions.

  2. #2
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    17,066
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Dell WiFi not working in clean 12.04 LTS

    Hi, welcome to the forum! Please open a terminal ctrl+alt+t copy and paste the following commands into it one line at a time, then paste the results here:
    Code:
    cat /etc/lsb-release; uname -a
    lspci -nnk | grep -iA2 net
    lsusb
    iwconfig
    rfkill list all
    lsmod
    by clicking on new reply and click # then paste the information between the brackets.
    Thank you

  3. #3
    Join Date
    Jul 2013
    Beans
    13

    Re: Dell WiFi not working in clean 12.04 LTS

    thanks for reply , please help me out this

    i facing this in win7 64 bit too , got no wifi to use
    Last edited by godleader; July 11th, 2013 at 09:11 PM.

  4. #4
    Join Date
    Jul 2013
    Beans
    13

    Re: Dell WiFi not working in clean 12.04 LTS

    Code:
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=12.04
    DISTRIB_CODENAME=precise
    DISTRIB_DESCRIPTION="Ubuntu 12.04.2 LTS"
    Linux dunno-Inspiron-3421 3.5.0-23-generic #35~precise1-Ubuntu SMP Fri Jan 25 17:13:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
    dunno@dunno-Inspiron-3421:~$ lspci -nnk | grep -iA2 net
    06:00.0 Network controller [0280]: Atheros Communications Inc. Device [168c:0036] (rev 01)
        Subsystem: Dell Device [1028:020c]
        Kernel modules: wl
    09:00.0  Ethernet controller [0200]: Realtek Semiconductor Co., Ltd.  RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev  05)
        Subsystem: Dell Device [1028:0591]
        Kernel driver in use: r8169
    dunno@dunno-Inspiron-3421:~$ lsusb
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 003 Device 002: ID 1058:1010 Western Digital Technologies, Inc. 
    Bus 003 Device 003: ID 046d:c058 Logitech, Inc. M115 Mouse
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 003: ID 064e:812c Suyin Corp. 
    dunno@dunno-Inspiron-3421:~$ iwconfig
    eth0      no wireless extensions.
    
    lo        no wireless extensions.
    
    dunno@dunno-Inspiron-3421:~$ rfkill list all
    dunno@dunno-Inspiron-3421:~$ lsmod
    Module                  Size  Used by
    nls_utf8               12558  1 
    udf                    94613  1 
    crc_itu_t              12708  1 udf
    dm_crypt               23126  1 
    snd_hda_codec_hdmi     32476  1 
    snd_hda_codec_realtek    79756  1 
    joydev                 17694  0 
    parport_pc             32867  0 
    ppdev                  17114  0 
    dell_wmi               12682  0 
    sparse_keymap          13891  1 dell_wmi
    snd_hda_intel          34117  3 
    snd_hda_codec         135141  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
    snd_hwdep              17765  1 snd_hda_codec
    snd_pcm                97523  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
    snd_seq_midi           13325  0 
    snd_rawmidi            30750  1 snd_seq_midi
    bnep                   18240  2 
    rfcomm                 47562  0 
    bluetooth             211812  10 bnep,rfcomm
    snd_seq_midi_event     14900  1 snd_seq_midi
    dell_laptop            17426  0 
    dcdbas                 14491  1 dell_laptop
    coretemp               13642  0 
    kvm_intel             137888  0 
    kvm                   422160  1 kvm_intel
    microcode              23030  0 
    snd_seq                61931  2 snd_seq_midi,snd_seq_midi_event
    snd_timer              29990  2 snd_pcm,snd_seq
    snd_seq_device         14498  3 snd_seq_midi,snd_rawmidi,snd_seq
    uvcvideo               78117  0 
    psmouse               102075  0 
    serio_raw              13216  0 
    mei                    41410  0 
    snd                     83674  16  snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    videobuf2_core         33025  1 uvcvideo
    videodev              125126  2 uvcvideo,videobuf2_core
    videobuf2_vmalloc      12861  1 uvcvideo
    videobuf2_memops       13405  1 videobuf2_vmalloc
    soundcore              15092  1 snd
    snd_page_alloc         18573  2 snd_hda_intel,snd_pcm
    cfg80211              524435  0 
    lpc_ich                17145  0 
    lib80211               14382  0 
    mac_hid                13254  0 
    lp                     17800  0 
    parport                46563  3 parport_pc,ppdev,lp
    hid_generic            12541  0 
    usbhid                 47259  0 
    hid                   100815  2 hid_generic,usbhid
    uas                    18073  0 
    usb_storage            49288  1 
    ghash_clmulni_intel    13221  0 
    aesni_intel            51134  189 
    cryptd                 20531  6 ghash_clmulni_intel,aesni_intel
    aes_x86_64             17256  1 aesni_intel
    i915                  599946  3 
    nouveau               941415  0 
    ttm                    83224  1 nouveau
    drm_kms_helper         49197  2 i915,nouveau
    drm                   276721  6 i915,nouveau,ttm,drm_kms_helper
    r8169                  62766  0 
    i2c_algo_bit           13565  2 i915,nouveau
    mxm_wmi                13022  1 nouveau
    video                  19598  2 i915,nouveau
    compat                 19346  5 cfg80211,i915,nouveau,ttm,drm
    wmi                    19257  3 dell_wmi,nouveau,mxm_wmi

  5. #5
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    17,066
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Dell WiFi not working in clean 12.04 LTS

    Okay your device is not supported in 12.04 but we can add it.

    First let's get rid of the wrong driver that you have loaded.
    Code:
    sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source
    Then follow the directions in post 26 of this link.
    http://ubuntuforums.org/showthread.php?t=2103062&page=3
    Thanks

  6. #6
    Join Date
    Jul 2013
    Beans
    13

    Re: Dell WiFi not working in clean 12.04 LTS

    Quote Originally Posted by Wild Man View Post
    Okay your device is not supported in 12.04 but we can add it.

    First let's get rid of the wrong driver that you have loaded.
    Code:
    sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source
    Then follow the directions in post 26 of this link.
    http://ubuntuforums.org/showthread.php?t=2103062&page=3
    Thanks
    sorry , i cant view the post 26 , it show until 20 only in page 2

    Results 11 to 20 of 29

  7. #7
    Join Date
    Jul 2013
    Beans
    13

    Re: Dell WiFi not working in clean 12.04 LTS

    thanks so much , its can show page 3 right now ... i am trying hope it will work

  8. #8
    Join Date
    Jul 2013
    Beans
    13

    Re: Dell WiFi not working in clean 12.04 LTS

    Quote Originally Posted by Wild Man View Post
    Okay your device is not supported in 12.04 but we can add it.

    First let's get rid of the wrong driver that you have loaded.
    Code:
    sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source
    Then follow the directions in post 26 of this link.
    http://ubuntuforums.org/showthread.php?t=2103062&page=3
    Thanks
    i've try still cant get it working and got error when trying to key in " sudo modprobe -r ath9k && sudo modprobe ath 9k"
    below are the msg show

    Code:
    WARNING: Error inserting ath (/lib/modules/3.5.0-23-generic/updates/drivers/net/wireless/ath/ath.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    WARNING: Error inserting ath9k_hw (/lib/modules/3.5.0-23-generic/updates/drivers/net/wireless/ath/ath9k/ath9k_hw.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    WARNING: Error inserting ath9k_common (/lib/modules/3.5.0-23-generic/updates/drivers/net/wireless/ath/ath9k/ath9k_common.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    WARNING: Error inserting mac80211 (/lib/modules/3.5.0-23-generic/updates/net/mac80211/mac80211.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    FATAL: Error inserting ath9k (/lib/modules/3.5.0-23-generic/updates/drivers/net/wireless/ath/ath9k/ath9k.ko): Unknown symbol in module, or unknown parameter (see dmesg)

  9. #9
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    17,066
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Dell WiFi not working in clean 12.04 LTS

    The link I provided is to page three when you click on it you should be taken to page three not two.
    What directions did you use to install the driver if you can not get to page three?
    thanks

  10. #10
    Join Date
    Jul 2013
    Beans
    13

    Re: Dell WiFi not working in clean 12.04 LTS

    Quote Originally Posted by Wild Man View Post
    The link I provided is to page three when you click on it you should be taken to page three not two.
    What directions did you use to install the driver if you can not get to page three?
    thanks
    sorry about that just now , it's my fault ,i am still new here .. hehe

    i've follow the posts 26
    download http://www.kernel.org/pub/linux/kern....7.9-1.tar.bz2
    and extract

    Code:
    cd Desktop/compat-drivers-3.7.9-1
    ./scripts/driver-select ath
    make
    sudo make install
    sudo modprobe -r ath9k && sudo modprobe ath9k
    the last command i got error
    Code:
    WARNING: Error inserting ath (/lib/modules/3.5.0-23-generic/updates/drivers/net/wireless/ath/ath.ko): Unknown symbol in module, or unknown parameter (see dmesg)WARNING: Error inserting ath9k_hw (/lib/modules/3.5.0-23-generic/updates/drivers/net/wireless/ath/ath9k/ath9k_hw.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    WARNING: Error inserting ath9k_common (/lib/modules/3.5.0-23-generic/updates/drivers/net/wireless/ath/ath9k/ath9k_common.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    WARNING: Error inserting mac80211 (/lib/modules/3.5.0-23-generic/updates/net/mac80211/mac80211.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    FATAL: Error inserting ath9k (/lib/modules/3.5.0-23-generic/updates/drivers/net/wireless/ath/ath9k/ath9k.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    after reboot it still same cant get it work ... please help this out

    thanks

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •