Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: "Documents" folder missing file type, cannot be opened

  1. #1
    Join Date
    Oct 2007
    Beans
    172
    Distro
    Ubuntu 14.04 Trusty Tahr

    "Documents" folder missing file type, cannot be opened

    I don't know how long this has been going on. I moved the Documents folder to another folder on my desktop and then later moved it back again.
    I also did this with the downloads, Pics, Music folders, etc. All the other folders are fine, but "Documents" can no longer be opened.
    I get a message saying the file type is unknown. I tried to right-click and re-associate it with nautilus, but the option is not available.
    I have stuff in there I need to get out. Anybody have an idea how I can open it again?

  2. #2
    Join Date
    Jul 2013
    Beans
    73

    Re: "Documents" folder missing file type, cannot be opened

    NEVER MOVE OR REMOVE THE DEFAULT FOLDERS IN HOME!!!! THEY WILL BREAK!!!

    Seriously, when you move the folders, as far as I'm aware, all symlinks to the folders break and apps that rely on those folders will no longer have automatic access to them. so you will have to manually point apps to them. I did that once to the Downloads folder where I deleted it by mistake and ever since nothing would download to it. I had to manually point everything, like Firefox, to the folder every time I downloaded. I have no idea if there is a fix, I ended up reinstalling my computer. So never mess with those folders. You can create shortcuts to them, but never move or delete them.

  3. #3
    Join Date
    Jul 2007
    Location
    Tāmaki Makau-rau, NZ
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: "Documents" folder missing file type, cannot be opened

    I would question what the previous poster is saying. I've done a number of installs where initially Documents, Pictures, Music etc did not exist at all and I had to create them manually. I've not had those problems.

    I wonder if the OP has not actually copied Documents back to the home directory but is trying to open a symlink that doesn't point anywhere. To check, open a terminal (ctrl-alt-t in most cases, or from the menu) and run the following commands:
    Code:
    cd
    ls -l
    The first command makes sure that you're in your home directory. If you know that you are, you can omit it.
    (that's lower-case l, not figure 1, in both cases)

    What does the line for "Documents" say?
    Ubuntu membership via Forums contributions
    BACKUP before installing or upgrading.

  4. #4
    Join Date
    Oct 2007
    Beans
    172
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: "Documents" folder missing file type, cannot be opened

    At the time I was only concerned with copying the content of the folders from another drive. I never imagined the folder would never open again and the contents would be lost!

  5. #5
    Join Date
    Jul 2013
    Beans
    73

    Re: "Documents" folder missing file type, cannot be opened

    @Irihapeti

    I wasn't kidding. True, I may be a fluke case, but I did mess up my home folder once and nothing would automatically use the folders like I demonstrated with Downloads. So I may be wrong here, but I was right in my moment of annoyance and terror that month ago.

  6. #6
    Join Date
    Oct 2007
    Beans
    172
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: "Documents" folder missing file type, cannot be opened

    -rwxr-xr-x 1 user user 277 2013-03-10 20:09 Documents.desktop

    which seems a bit different from the other folders, which look like this:

    drwxr-xr-x 5 user user 28672 2013-07-06 18:23 Downloads
    drwxr-xr-x 2 user user 4096 2013-02-24 19:53 Music
    drwxr-xr-x 2 user user 4096 2013-03-10 18:19 Pics
    drwxr-xr-x 2 user user 4096 2010-05-19 20:11 Videos

  7. #7
    Join Date
    Jul 2007
    Location
    Tāmaki Makau-rau, NZ
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: "Documents" folder missing file type, cannot be opened

    Quote Originally Posted by BreezyBrooke View Post
    @Irihapeti

    I wasn't kidding. True, I may be a fluke case, but I did mess up my home folder once and nothing would automatically use the folders like I demonstrated with Downloads. So I may be wrong here, but I was right in my moment of annoyance and terror that month ago.
    No problem. I'm not doubting it happened to you, and I can well imagine that it would be extremely scary. I'm just not sure that it's a general principle, that's all. Perhaps I could have worded it better.

    Hopefully the OP will come back with the answer to my question, and that will give us a better idea of what might be going on.
    Ubuntu membership via Forums contributions
    BACKUP before installing or upgrading.

  8. #8
    Join Date
    Jul 2007
    Location
    Tāmaki Makau-rau, NZ
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: "Documents" folder missing file type, cannot be opened

    Then that's not a folder at all. It's a .desktop file which is usually used for starting up a program. It can be opened in a text editor.

    I hope you still have the copy of the documents folder somewhere else, or a good backup, because I think they are going to be your only options.
    Ubuntu membership via Forums contributions
    BACKUP before installing or upgrading.

  9. #9
    monkeybrain2012 is offline Grande Half-n-Half Cinnamon Ubuntu
    Join Date
    Oct 2012
    Beans
    874

    Re: "Documents" folder missing file type, cannot be opened

    Open your home directory in Nautilus, either do "ctr h" or go to View > Show hidden files and locate the hidden directory .config, open it and open the file user-dirs.dirs with the text editor (right clicking) You should find the line

    Code:
    XDG_DOCUMENTS_DIR="$HOME/Documents"
    If instead you have just
    Code:
    XDG_DOCUMENTS_DIR="$HOME/"
    It may be the source of your problem, in that case just add back "Documents" as above (without quotations) and see if that helps.
    Last edited by monkeybrain2012; July 7th, 2013 at 02:44 AM.

  10. #10
    Join Date
    Oct 2007
    Beans
    172
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: "Documents" folder missing file type, cannot be opened

    The entry in the .config was showing just

    XDG_DOCUMENTS_DIR="$HOME/"

    but changing it to

    XDG_DOCUMENTS_DIR="$HOME/Documents"

    had no effect. Still getting the message "Could not display "home/user/Documents".
    The file is of an unknown type.

    Then there are options [Select Application] & [OK]

    There are no applications showing in the menu. I have to go to Other Applications and the only thing I can find there is Files, but that doesn't work.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •