Results 1 to 3 of 3

Thread: No wireless in UBuntu 13.14

  1. #1
    Join Date
    Jun 2006
    Beans
    468

    No wireless in UBuntu 13.14

    I am running a dell xps m1530 with latest ubuntu and here is my wireless information:

    mike@mike-XPS-M1530:~$ lspci
    00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
    00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port (rev 0c)
    00:1a.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 02)
    00:1a.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 02)
    00:1a.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 02)
    00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
    00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 02)
    00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 02)
    00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 02)
    00:1d.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 02)
    00:1d.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 02)
    00:1d.2 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 02)
    00:1d.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 02)
    00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f2)
    00:1f.0 ISA bridge: Intel Corporation 82801HM (ICH8M) LPC Interface Controller (rev 02)
    00:1f.1 IDE interface: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 02)
    00:1f.2 SATA controller: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode] (rev 02)
    00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
    01:00.0 VGA compatible controller: NVIDIA Corporation G86M [GeForce 8400M GS] (rev a1)
    03:09.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
    03:09.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
    03:09.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
    03:09.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)
    09:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller (rev 12)
    0b:00.0 Network controller: Broadcom Corporation BCM4321 802.11a/b/g/n (rev 03)
    mike@mike-XPS-M1530:~$


    Right now I have no wireless option.

  2. #2
    Join Date
    Jun 2013
    Location
    Canada
    Beans
    136
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: No wireless in UBuntu 13.14

    Just making sure, I think the Dell has a button to turn on/off wireless. Did you try that already?
    Failing that, you can try the steps outlined in this post by irv. He seemed to have gotten it going:
    http://ubuntuforums.org/showthread.php?t=2005942

  3. #3
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,149
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: No wireless in UBuntu 13.04

    Please edit the title of your thread (by editing the first post in advance mode) to correct the version to "13.04". There is no 13.14 and never will be

    Quote Originally Posted by searayman View Post
    0b:00.0 Network controller: Broadcom Corporation BCM4321 802.11a/b/g/n (rev 03)
    There are four different chips with the same chip ID (BCM4321). To see exactly which one you have and possibly the driver in use, please post the output of -
    Code:
    lspci -nnk | grep -iA2 net
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •