Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: 13.04 Printing- sees USB printer won't 'set up'

  1. #11
    Join Date
    Apr 2009
    Beans
    194
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 13.04 Printing- sees USB printer won't 'set up'

    looks like the forums won't accept the whole error_log file, here is the first portion:
    Code:
    E [03/Jul/2013:07:17:12 -0400] [cups-driverd] Bad driver information file "/usr/share/cups/drv/cupsfilters.drv"!
    E [03/Jul/2013:07:18:16 -0400] [cups-driverd] Bad driver information file "/usr/share/cups/drv/cupsfilters.drv"!
    E [03/Jul/2013:07:20:42 -0400] [cups-driverd] Bad driver information file "/usr/share/cups/drv/cupsfilters.drv"!
    I [03/Jul/2013:07:21:28 -0400] Listening to 0.0.0.0:631 (IPv4)
    I [03/Jul/2013:07:21:28 -0400] Listening to [v1.::]:631 (IPv6)
    I [03/Jul/2013:07:21:28 -0400] Listening to /var/run/cups/cups.sock (Domain)
    I [03/Jul/2013:07:21:28 -0400] Remote access is enabled.
    D [03/Jul/2013:07:21:28 -0400] Added auto ServerAlias warning
    I [03/Jul/2013:07:21:28 -0400] Loaded configuration file "/etc/cups/cupsd.conf"
    I [03/Jul/2013:07:21:28 -0400] Using default TempDir of /var/spool/cups/tmp...
    I [03/Jul/2013:07:21:28 -0400] Configured for up to 100 clients.
    I [03/Jul/2013:07:21:28 -0400] Allowing up to 100 client connections per host.
    I [03/Jul/2013:07:21:28 -0400] Using policy "default" as the default.
    I [03/Jul/2013:07:21:28 -0400] Full reload is required.
    I [03/Jul/2013:07:21:28 -0400] Saving job.cache...
    I [03/Jul/2013:07:21:29 -0400] Loaded MIME database from "/usr/share/cups/mime" and "/etc/cups": 39 types, 56 filters...
    I [03/Jul/2013:07:21:29 -0400] Loading job cache file "/var/cache/cups/job.cache"...
    D [03/Jul/2013:07:21:29 -0400] cupsdAddSubscription(mask=0, dest=(nil)(), job=(nil)(0), uri="(null)")
    D [03/Jul/2013:07:21:29 -0400] cupsdAddSubscription(mask=0, dest=(nil)(), job=(nil)(0), uri="(null)")
    D [03/Jul/2013:07:21:29 -0400] cupsdAddSubscription(mask=0, dest=(nil)(), job=(nil)(0), uri="(null)")
    D [03/Jul/2013:07:21:29 -0400] cupsdAddSubscription(mask=0, dest=(nil)(), job=(nil)(0), uri="(null)")
    D [03/Jul/2013:07:21:29 -0400] cupsdAddSubscription(mask=0, dest=(nil)(), job=(nil)(0), uri="(null)")
    I [03/Jul/2013:07:21:29 -0400] Full reload complete.
    I [03/Jul/2013:07:21:29 -0400] Listening to 0.0.0.0:631 on fd 9...
    I [03/Jul/2013:07:21:29 -0400] Listening to [v1.::]:631 on fd 10...
    I [03/Jul/2013:07:21:29 -0400] Listening to /var/run/cups/cups.sock:631 on fd 11...
    I [03/Jul/2013:07:21:29 -0400] Resuming new connection processing...
    D [03/Jul/2013:07:21:29 -0400] cupsdSetBusyState: newbusy="Not busy", busy="Not busy"
    D [03/Jul/2013:07:21:29 -0400] Notifier dbus started - PID = 2540
    D [03/Jul/2013:07:21:29 -0400] Notifier dbus started - PID = 2541
    D [03/Jul/2013:07:21:29 -0400] cupsdMarkDirty(----S)
    D [03/Jul/2013:07:21:29 -0400] cupsdSetBusyState: newbusy="Dirty files", busy="Not busy"
    D [03/Jul/2013:07:21:29 -0400] [Notifier] state=3
    Ubuntu 12.04.2_amd_64_LTS on Desktop run by Intel core I5 3570K on Asus P8Z77-V Pro MB

    Ubuntu 12.04 LTS on Lenovo N500 laptop

  2. #12
    Join Date
    Jun 2013
    Location
    Canada
    Beans
    136
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: 13.04 Printing- sees USB printer won't 'set up'

    Ah, that's a shame. Well, I'm looking for the things around /usr/lib/cups/filter/gstoraster failing, since I think that may give an insight to what is going on. You could use http://pastebin.com to post the entire log, I think.

    As to the installing of packages, I think you can look up the downloaded package in your file manager and click on it from there. That's how it works for me in KDE4 anyway.

  3. #13
    Join Date
    Apr 2009
    Beans
    194
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 13.04 Printing- sees USB printer won't 'set up'

    I didn't install the whole packagae over fears of breaking my system further over the "low quality" message when I attempted to install it, so I unpacked the PPD file and the 'rasteroz600' file to the desktop, kind of like building a driver in the GUI environment, impossible for me I think. Doesn't the rastoroz600 file have to be installed in the correct folder and reported to and by several other locations related to CUPS? I'm guessing that the lack of the correct install of these driver files are the root of the problems with printing here - maybe these aren't 64-bit compatible?
    Ubuntu 12.04.2_amd_64_LTS on Desktop run by Intel core I5 3570K on Asus P8Z77-V Pro MB

    Ubuntu 12.04 LTS on Lenovo N500 laptop

  4. #14
    Join Date
    Jun 2013
    Location
    Canada
    Beans
    136
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: 13.04 Printing- sees USB printer won't 'set up'

    Well, as far as I know ppd files are just text files, so they should work regardless if your OS is 32- or 64-bit. There are quite a few of those in /usr/share/ppd/cupsfilters
    I'm not sure if CUPS would pick it up after a restart if you put it there though.

  5. #15
    Join Date
    Apr 2009
    Beans
    194
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 13.04 Printing- sees USB printer won't 'set up'

    yes, I wondered about stuff like that as well, so I just installed 12.04.2 64, the good news is it appears to be working as well as 12.4.2 32 bit, i.e. I have the dialogues for "additional drivers" and a place I can put a ppd for printing,I haven't fixed it yet, but hopes are high. Thanks for your help.
    Ubuntu 12.04.2_amd_64_LTS on Desktop run by Intel core I5 3570K on Asus P8Z77-V Pro MB

    Ubuntu 12.04 LTS on Lenovo N500 laptop

  6. #16
    Join Date
    Apr 2009
    Beans
    194
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 13.04 Printing- sees USB printer won't 'set up'

    DeathByDenim, I was able to get the printer working in 12.04.2 but I had to add the 32-bit libs to get it to work. I discovered this error by going back through the old HowTo contained in my thread at the link you posted and reading it and then adding the 32 bit libs, I didn't have to reinstall the driver or anything, it just started working, so there is a big difference with the drivers when it comes to 32 vs 64 bit.This should work in 13.04 as well.
    Last edited by alvinmoneypit; July 4th, 2013 at 11:05 PM.
    Ubuntu 12.04.2_amd_64_LTS on Desktop run by Intel core I5 3570K on Asus P8Z77-V Pro MB

    Ubuntu 12.04 LTS on Lenovo N500 laptop

  7. #17
    Join Date
    Apr 2009
    Beans
    194
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 13.04 Printing- sees USB printer won't 'set up'

    So reviewing what I did to get a Lexmark X1150 printer working (in Black ink only), I downloaded the z600 deb, derived the PPD file from the deb by opening it with Archive Manager and navigating through the folders: USR>SHARE>CUPS>MODEL>.ppd and extracting it to the desktop, accessed the CUPS through Firefox and added the printer (Administration on top of the page, then "add Printer"), then, since I'm running a 64-bit version, I added the 32-bit libs by pasting the following code into the terminal window (this takes a while to complete):
    Code:
    sudo apt-get install ia32-libs alien
    It would probably be better if 64-bit users enter the above code first to get the libs.
    If this doesn't work for your Lexmark model, this thread is where I got most of the info I needed to fix my print driver, it is old and for older distro's, but it worked for me.
    Last edited by alvinmoneypit; July 5th, 2013 at 12:12 AM.
    Ubuntu 12.04.2_amd_64_LTS on Desktop run by Intel core I5 3570K on Asus P8Z77-V Pro MB

    Ubuntu 12.04 LTS on Lenovo N500 laptop

  8. #18
    Join Date
    Jun 2013
    Location
    Canada
    Beans
    136
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: 13.04 Printing- sees USB printer won't 'set up'

    Nice! I'm glad you got it working!
    Weird about the only grey-scale printing part though. Oh well.

  9. #19
    Join Date
    Apr 2009
    Beans
    194
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 13.04 Printing- sees USB printer won't 'set up'

    DeathByDenim,
    Weird about the only grey-scale printing part though. Oh well.
    That's the way this printer has always been as long as I've had it, someone gave it to me . The z600 driver was not original to this printer, but was the most used and easiest solution I found. I may have been able to find one that supports color properly but my color cartridge holder is broken anyway and I don't print color stuff anyway. Color inkjet stuff uses a lot of ink, If I need something in color I usually need more than one copy so I put it on a USB and off to the local printers. This is a really old printer now, first issued in 2003 I think.
    Ubuntu 12.04.2_amd_64_LTS on Desktop run by Intel core I5 3570K on Asus P8Z77-V Pro MB

    Ubuntu 12.04 LTS on Lenovo N500 laptop

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •