Results 1 to 2 of 2

Thread: 13.04 aircrack/compact/patch issues?

  1. #1
    Join Date
    Oct 2011

    Unhappy 13.04 aircrack/compact/patch issues?

    Hey guys,
    I've been trying to figure out why this isn't working. I have ubuntu 13.04, Intel Wireless Centrino 6200 running iwlwifi which is supported, aircrack 1.1, wifite/etc. Everything I have found after days of searching is that everything is included in ubuntu 13.04 (as far as compact/etc goes) since the 3.8 kernel. I'm running and everything almost works perfect however some issues especially with this infamous channel negative 1 issue - of which apparently the patch no longer works because it's included in the compact built in the kernel (from what I've read). I run wifite, it shows everything seemingly fine but WPS is always NO (which is incorrect, I run kali and it works flawlessly on 3.7 kernel), reaver runs but doesn't do anything as it doesnt go beyond waiting for broadcast, and airodump is stuck on the -1 channel. I have a feeling all of these issues go back to the -1 issue. Has ANYONE gotten this to work on 13.04? I've seen posts which are seemingly helpless for 13.04 due to the patch not applying issue, and also note I have not applied any patches due to finding that they should be supported to begin with. A post on aircrack complained of the same but the dev just came back saying 'works for me' and closed it so that wasn't very helpful. Hopefully SOMEONE out there has gotten it to work? Do I need to upgrade aircrack NOT using the pkg manager? Do I need to compile the compact 3.9/aircrack ack/etc patch and just ignore the channel -1 patch? ANY ideas would be very helpful, thanks guys!

    - wifite/aircrack/etc works to scan, but always shows WPS as off which is INCORRECT
    - airodump stuck at channel -1
    - reaver doesn't get past waiting for broadcast (guessing due to being stuck on channel -1) even when specify a channel
    - aireplay test seems to run but doesn't say injection is working, everything else looks similar but it JUST finds ONE of my wireless network (no others) which doesn't give it any results

    - Ubuntu 13.04
    - uname -a: Linux (host) 3.8.0-25-generic #37-Ubuntu SMP Thu Jun 6 20:47:07 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
    - Intel Wireless Centrino 6200 (iwlwifi being used)

    - Have not applied any patches (compact/aircrack ack/negative 1 channel/etc) as searching has found that channel 1 patch does not work and should be included in compact 3.9.xx which should be included in ubuntu 13.04 by default (due to 3.8.x kernel)

    I know it's supported obviously as mentioned Kali has 0 issues above and is running a 3.7 kernel, however I have that tripple booted on a SMALL partition and it bugs up a lot even though latest version mouse buttons die/can't do ANYTHING but type in open terminal/etc so do not want to use that, plus ubuntu being my daily driver I would like to be able to run quick aircrack tests without having to switch to kali/etc which I have to manually get to boot due to a issue with their 1.0.3 x64 iso when using encrypted paritions beneath an LVM partition as I can't seem to get it to activate the LVM's before it runs cryptsetup, however don't want to go into that right now haha.

    Do I need to still run the aircrack patch with the latest compact? From what I've seen this doesn't help again based off LOTS of advanced googling & forum searches, apparently just not finding the right one. One that I did find that I BELIEVE said solved it, but not exactly so was unsure, led to this link: which of course the linux-headers/etc are not valid for raring as those are not in the repos, however I could apt-get install my generic headers and try the rest, but at this point after seeing so many people trying with no solutions/solved I wanted to just post around to see if anyone knew for sure so I don't end up messing with something to the point of breaking as I did with my intel driver back on 12.04 haha, thanks guys.

    Upgraded aircrack to 1.2 beta 1 and no change in any of the above.
    Last edited by Hazey11; June 30th, 2013 at 02:01 AM. Reason: upgraded aircrack 1.2beta1 no change

  2. #2
    Join Date
    Feb 2008
    Ubuntu Gnome Development Release

    Re: 13.04 aircrack/compact/patch issues?

    Aircrack is not supported on the forum your best option is backtrack forum or I believe aircrack has its own forum now.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts