Results 1 to 2 of 2

Thread: [ubuntu] Xen kernel stuck while booting

  1. #1
    Join Date
    Jun 2013

    Question [ubuntu] Xen kernel stuck while booting

    Dear Xen experts,

    I'm trying to get Ubuntu's Xen to work on my desktop, following Ubuntu's Xen guide. Unfortunately, the Xen kernel hangs up while booting - -at different steps. It does not recognize Ctrl+Alt+Delete but requires the reset button to be used.


    Installing the plain Ubuntu 12.04 worked well, installation of xen-hypervisor-4.1-amd64 which pulls Xen 4.1 was fine, grub and toolstack were changed as explained.

    Console output ends at:
    (XEN) HVM: ASIDs enabled.
    (XEN) HVM: VMX enabled
    (XEN) HVM: Hardware Assisted Paging detected.
    (XEN) revised cpuid_level = 13
    (XEN) revised cpuid_level = 13
    (XEN) revised cpuid_level = 13
    (XEN) revised cpuid_level = 13
    Intriguing, since I would have assumed that this message, if repeated a few times, would be printed for each CPU core found, but there are six cores in this CPU. The message revised cpuid_level = 13 can be removed if the BIOS setting "Limit CPUID Maximum".

    Another time, it ends at:
    (XEN) Xen version 4.1.2 (Ubuntu 4.1.2-2ubuntu2.10) [...]
    (XEN) Bootloader: GRUB 1.99-21ubuntu3.9
    (XEN) Command line: placeholder
    (XEN) Disc information:
    (XEN)  Found 0 MBR signatures
    (XEN)  Found 0 EDD information structures
    (XEN) Xen-e801 RAM map:
    (XEN)  0000000000000000 - 000000000009e800 (usable)
    (XEN)  0000000000100000 - 00000000dca00000 (usable)
    The BIOS setting "CPU Intel Virtualization Technology" (VMM may utilize VT hardware capabilities) and "VT-d" are activated.


    CPU Intel Core i7-3970X @ 3.50GHz
    Mainboard ATI Rampage IV Extreme
    Memory 16 GByte DDR3-1600
    BIOS Asus Rampage IV Extreme ACPI BIOS Revision 3602
    Chipset Intel X79 Express


    Ubuntu 12.04 server 12.10 server
    Kernel 3.5.0-34 3.5.0-34
    xen-hypervisor-amd64 4.1.2-2ubuntu2.10 4.1.3-3ubuntu1.7

    Can anybody give advice?

    Update (Edit)

    Upgraded to Ubuntu 12.10. Xen fails to boot but does no longer hang up at some recognizable step, but reboots after too many lines scrolling too fast. Thus, the problem still exists. Trying upgrade to 13.04.

    Update (Edit)

    Upgraded to Ubuntu 13.04 server, kernel 3.8.0-25, xen-hypervisor 4.2.1-0ubuntu3.3. Works (I guess). Problem solved.
    Last edited by Twonky; June 28th, 2013 at 05:41 PM.

  2. #2
    Join Date
    Apr 2008
    Ubuntu Mate 16.04 Xenial Xerus

    Re: [ubuntu] Xen kernel stuck while booting

    Try booting into a regular kernel (non-Xen) and check the logs under /var/log/xen as well as /var/log/dmesg.0. In the latter see where exactly it hangs. What's your graphics card for dom0? And what's the driver for it?
    LM18.1 64bit (Ubuntu 16.04) with a Windows 10 Pro 64 bit kvm guest using VGA passthrough


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts