Page 4 of 11 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 110

Thread: HOWTO: TV-out for legacy ATI cards using GATOS

  1. #31
    Join Date
    Dec 2006
    Beans
    40
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: HOWTO: TV-out for legacy ATI cards using GATOS

    hey for that last post, could you provide more specific directions please?
    I had the same problem. I made a few changes to my source code, and it now compiles ok. But then I realised I already had xserver-xorg-video-ati installed, which conflicts with this package.

    Anyway, I've attached a patch file that should do the trick. Uncompress the archive, navigate to the src/ directory, and run the following command:

    Code:
    patch -p1 -i myfix.patch
    Note: having decided not to install this package, I'm not sure my changes result in a working driver set up. I just got it compiling...
    Attached Files Attached Files

  2. #32

    Re: HOWTO: TV-out for legacy ATI cards using GATOS

    [QUOTE=dmjones500;1873440

    Note: having decided not to install this package, I'm not sure my changes result in a working driver set up. I just got it compiling...[/QUOTE]

    this is my output
    Code:
    patch unexpectedly ends in middle of line
    patch: **** Only garbage was found in the patch input.
    And I m not able to open your patch by text editor..

    Thanks,

    MiRr0r

  3. #33
    Join Date
    Dec 2006
    Beans
    40
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: HOWTO: TV-out for legacy ATI cards using GATOS

    Strange, something seems to have corrupted the file. I untarred the copy I uploaded and it was garbage for me too...

    I've uploaded it with a .txt extension now.
    Attached Files Attached Files

  4. #34
    Join Date
    Dec 2006
    Beans
    2

    Re: HOWTO: TV-out for legacy ATI cards using GATOS

    Obviously you're not looking at the correct radeon_exa.c and radeon_exa_accel.c. If you were, then you should see a card and accel fields which caused the compilation error to begin with.

    Please follow the instructions in my previous post and apply them to you're
    xf86-video-ati-6.5.8.0/src/radeon_exa.c and xf86-video-ati-6.5.8.0/src/radeon_exa_funcs.c.

    If you followed the instructions for installing this driver (as described in the beginning of this forum) you should have these files after untaring xf86-video-ati-6.5.8.0.tar.bz2 and applying xorg7-6.5.8.0-tv_output.patch.gz.

  5. #35
    Join Date
    Dec 2006
    Location
    Mount Washingto
    Beans
    9
    Distro
    Ubuntu 6.10 Edgy

    Re: HOWTO: TV-out for legacy ATI cards using GATOS

    Does anyone know if this works with an ATI Rage Mobility 128? I have a PowerBook "Pismo" I am trying to get the tv out to work on. I'm not having any luck. I followed the HowTo to the T. I don't know wether it's not working because I'm using a powerpc arch or because I'm screwing something up. Everthing installed ok with no errors, the only thing I noticed is that when I went into the config.log I found a line that said

    configure:20511: checking whether to include TV Out support
    configure:20513: result: no

    Any help would be great.

  6. #36
    Join Date
    Jan 2007
    Beans
    7

    Re: HOWTO: TV-out for legacy ATI cards using GATOS

    I just updated to Edgy and tried patching according to PooBaa's instructions. Everything seems to go well, but my computer hangs completely when starting xorg. I can't find any errors on xorg.0.log or messages log. Any ideas what to try next? Is there any chance I should be using different files from the ones in the guide? My card is Radeon 7200 VIVO
    Last edited by Naranek; January 6th, 2007 at 04:25 PM.

  7. #37
    Join Date
    Jan 2006
    Location
    Socorro, New Mexico, USA
    Beans
    17

    Re: HOWTO: TV-out for legacy ATI cards using GATOS

    Hi all,

    First I want to say what fantastic instructions you gave. Thank you for creating this post and providing this information. I had no trouble following them and successfuly downloaded, patched, compiled, installed, and configured TV out following these instructions. I encountered no errors or warnings as I did this. However, it did not work. After chasing down a faulty TV in plug on one TV, I get nothing on the TV screen after X starts.

    Contrary to the list of supported cards at the Gatos site, the patch supplied does not touch the r128 driver source files. It does not enable TV out for these cards. If your card is not a Radeon, it will not work. However, the TV Out on my Rage 128 pro card does work until the frame buffer is enabled (Ubuntu splash screen) and/or until the X server starts.

    When I find a way to enable TV out I will come back and post how I was able to make it work.

    William

  8. #38
    Join Date
    Jul 2006
    Beans
    90

    Re: HOWTO: TV-out for legacy ATI cards using GATOS

    First off, I appreciate the hard work that has gone into this guide... but at its current state i find it nearly unusable.

    Would anyone mind posting a revised and complete set of instructions? Trying to find my way through all this muck is more likely to break my system than fix it.

    I did try, and got to "make" and it was missing packages. Tried to install the suggested packages from a few posts ago and all but two were installed and those two were unavailable.

    So.

    Someone.

    Please.

    Re-write this.


    (soon?)

  9. #39
    Join Date
    Dec 2006
    Beans
    8
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: TV-out for legacy ATI cards using GATOS

    Quote Originally Posted by CyberCod View Post
    So.

    Someone.

    Please.

    Re-write this.


    (soon?)


    Right. For edgy, it's just a little bit of the original post, and a little bit of PooBaa's post. Once you've got the driver installed, the original howto is all you need.

    install driver
    1. install packages
      HTML Code:
      sudo apt-get install build-essential libdrm-dev mesa-common-dev \
      render-dev x11proto-core-dev x11proto-fonts-dev x11proto-gl-dev \
      x11proto-randr-dev x11proto-video-dev x11proto-xext-dev \
      x11proto-xf86dri-dev x11proto-xf86misc-dev x11proto-xinerama-dev \
      xserver-xorg-dev pkg-config
    2. get the driver
      HTML Code:
      mkdir ~/ati
      cd ~/ati
      wget http://megahurts.dk/rune/stuff/xorg7.1-6.6.3-tv_output.patch.gz
      wget http://xorg.freedesktop.org/releases/individual/driver/xf86-video-ati-6.6.3.tar.bz2
    3. patch the driver
      HTML Code:
      tar xjvf xf86-video-ati-6.6.3.tar.bz2
      gunzip -c xorg7.1-6.6.3-tv_output.patch.gz | patch -p1 -d xf86-video-ati-6.6.3
    4. configure, build and install the driver
      HTML Code:
      cd xf86-video-ati-6.6.3
      export XORG_PREFIX="/usr"
      export XORG_CONFIG="--prefix=$XORG_PREFIX --sysconfdir=/etc --localstatedir=/var"
      ./configure $XORG_CONFIG --with-xorg-module-dir=$XORG_PREFIX/lib/xorg/modules
      make
      sudo make install



    tweak xorg.conf
    add the bits in bold

    Code:
    Section "Device" 
        Identifier "ATI Technologies, Inc. Radeon RV100 QY [Radeon 7000/VE]" 
        Driver "ati" 
        BusID "PCI:1:0:0" 
        Option "TVOutput" "NTSC"
    EndSection
    Code:
    Section "Monitor"
        Identifier "SyncMaster"
        HorizSync 30 - 50
        VertRefresh 60 - 60
        Option "DPMS"
    EndSection
    Code:
    Section "Screen"
        Identifier "Default Screen"
        Device "ATI Technologies, Inc. Radeon RV100 QY [Radeon 7000/VE]" 
        Monitor "SyncMaster" 
        DefaultDepth 24 
        SubSection "Display" 
            Depth 24 
            Modes "800x600" 
        EndSubSection 
    EndSection

    if you want explanations about why you do any of this, read the original howto. it really is quite good.



    update, 13 august 2007, for 7.04 support
    1. add "pkg-config" to the long list of packages to install
    2. make sure the Driver is "ati" and not "vesa" in xorg.conf. i've bolded it to make sure you don't miss it.



    everything else seems to be okay.
    Last edited by dlg; August 13th, 2007 at 09:25 PM. Reason: added pkg-config to the install list.

  10. #40
    Join Date
    Dec 2006
    Beans
    8
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: TV-out for legacy ATI cards using GATOS

    and now, I have a question.

    This works very well, with one notable problem: the picture on the tv is shifted up and to the right about an inch.

    Anybody know how to fix this? I'd like to be able to see the top and right edges of the display.

Page 4 of 11 FirstFirst ... 23456 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •