Results 1 to 6 of 6

Thread: Enigmail stopped working - " gpg: problem with the agent - disabling agent use"

  1. #1
    Join Date
    Sep 2006
    Beans
    8,627
    Distro
    Ubuntu 14.04 Trusty Tahr

    Enigmail stopped working - " gpg: problem with the agent - disabling agent use"

    I've got Thunderbird with Engimail on Lubuntu Saucy. Engimail has been working fine until a few days ago when it stopped working. I get the following message when I check "details" on a message:


    OpenPGP Security Info

    Error - signature verification failed

    gpg command line and output:
    gpg
    gpg: problem with the agent - disabling agent use
    gpg: can't query passphrase in batch mode
    gpg: Invalid passphrase; please try again ...
    gpg: can't query passphrase in batch mode
    gpg: Invalid passphrase; please try again ...
    gpg: can't query passphrase in batch mode
    gpg: encrypted with 1024-bit ELG-E key, ID XXXXXXXX, created 2004-01-09
    "xxxx <xx@xxxxx.com>"
    gpg: encrypted with 2048-bit ELG-E key, ID XXXXXXXX, created 2008-03-04
    "xxxxx <xxxx@xxxx.com>"
    gpg: public key decryption failed: bad passphrase
    gpg: decryption failed: secret key not available

    The same files and settings work fine with Debian wheezy and IceDove, but no longer with Thunderbird on Saucy. I've even tried installing the system again from daily snapshot ISO image and the problem persists. It looks like there is something wrong with the agent, but the question is what and how to fix it.

  2. #2
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Enigmail stopped working - " gpg: problem with the agent - disabling agent use"

    I've used the same ~/.gnupg directory for the past several releases, as it gets backed up during my weekly home directory backup. The only thing I can think of is that it may be a permission issue.

    • pubring.gpg
    • trustdb.gpg



    both have permissions of 700, all the other directories and files have permissions set to 777.

  3. #3
    Join Date
    Sep 2006
    Beans
    8,627
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Enigmail stopped working - " gpg: problem with the agent - disabling agent use"

    Maybe 777 is a typo? I hope.

    The problem here is with Thunderbird or with something tha Thunderbird interacts with. gpg works in the shell just fine I think the main clue might be in this line of the error message:

    Code:
     gpg: problem with the agent - disabling agent use
    I'm not sure which agent or how to check it. I looked in Menu->Preferences->Desktop Session Settings->GPG Password Agent and that box is checked.

  4. #4
    Join Date
    Aug 2013
    Beans
    1

    Re: Enigmail stopped working - " gpg: problem with the agent - disabling agent use"

    Same problem and same setup here.
    Temporary fix that works for me: in a terminal window type `killall gpg-agent`
    You will have to do this after every login
    If you want to contribute to the solution of the problem, file a bug report, not a forum complaint.
    * https://wiki.ubuntu.com/Lubuntu/ReportingBugs
    Possible pointers for further research:
    * http://serverfault.com/questions/481...t-doesnt-exist
    * http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=642021

  5. #5
    Join Date
    Dec 2013
    Beans
    1

    Re: Enigmail stopped working - " gpg: problem with the agent - disabling agent use"

    I’ve solved this issue unchecking the “Never ask for any passphrase” in the basic tab of the enigmail preferences

  6. #6
    Join Date
    Mar 2014
    Beans
    1

    Re: Enigmail stopped working - " gpg: problem with the agent - disabling agent use"

    I changed the /usr/bin/pinentry from pointing to pinentry-qt4 to pointing to pinentry-gtk-2. This resolved the issue.
    credits for the this solution go to http://sourceforge.net/p/enigmail/fo...ee2a2a62/#7e11

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •