Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 41

Thread: 2013 Macbook Air w/ Haswell & Intel 5000 Graphics

  1. #21
    Join Date
    Feb 2009

    Re: 2013 Macbook Air w/ Haswell & Intel 5000 Graphics

    Saucy final is now released. Did you use the ubuntu-13.10-desktop-amd64+mac.iso or the ubuntu-13.10-desktop-amd64.iso ? Please try with the ubuntu-13.10-desktop-amd64.iso if not used so far.
    I have successfully installed 13.10 now. Detailed instructions follow...

  2. #22
    Join Date
    Oct 2013

    Re: 2013 Macbook Air w/ Haswell & Intel 5000 Graphics

    I used the final release desktop-amd64.iso
    I was able to get a full read of the error I get when booting:
    Could not open "\EFI\BOOT\fallback.efi"

  3. #23
    Join Date
    Feb 2009

    Re: 2013 Macbook Air w/ Haswell & Intel 5000 Graphics

    # Installation of Ubuntu 13.10 on Macbook Air 6,2 (Mid2013)

    ## Prerequisites
    1. MacBookAir6,2
    * Check on OSX with `sysctl hw.model`
    * Check on linux with `sudo dmidecode -s system-product-name`
    2. Apple USB-Ethernet Adapter
    3. USB-Stick (1GB at least)
    4. `ubuntu-13.10-desktop-amd64.iso` from
    Note: Do not use the 'amd64+mac' iso image as here the USB-Stick cannot boot. (Do not ask me why.)

    ## Partition Harddisk
    1. Boot Macbook Air into OSX
    2. Open Disk Utility
    open /Applications/Utility/Disk\
    3. Select "Macintosh HD" > (Tab)Partition
    Add (+) 3 more partitions
    4. 2nd Partition: Set 30-40GB for Ubuntu "/"
    4th Partition: Set 4GB for Linux Swap partition
    3rd Partition: Use as much space as left for "/home"

    ## Prepare USB-Stick
    1. In OSX
    2. Download iso image to ~/Downloads
    3. Open Terminal (a detailed description can be found [here](
    cd ~/Downloads
    # convert iso
    hdiutil convert -format UDRW -o ubuntu-13.10-desktop-amd64.img ubuntu-13.10-desktop-amd64.iso
    open /Applications/Utilities/Disk\
    # format the USB stick with MS-DOS VFAT
    diskutil list
    # check which /dev/diskX contains the USB stick - here it is "disk1"
    # then unmount the usb-stick
    diskutil unmountDisk /dev/disk1
    # write img to usb stick - /!\ BE CAREFUL THAT disk1 REALLY IS YOUR USB-STICK
    sudo dd if=ubuntu-13.10-desktop-amd64.img.dmg of=/dev/rdisk1 bs=1m
    ## Install Ubuntu 13.10
    1. Restart and press "Alt"-Key on startup.
    2. Make sure that the USB-Ethernet Adapter is NOT inserted. (With a network connection the bcmwl-kernel-source module gets downloaded during the installation process which prevents grub to get installed; DKMS module insertion stops installation process).
    Select first USB-device labled "EFI-Boot" and press "Enter"
    No splash screen shall be displayed but the Ubuntu installation menu.
    Check [Identifying if the computer boots the Ubuntu DVD in EFI mode](
    Select "Install Ubuntu"
    3. Choose "Something else" for partitioning.
    Please check the sizes in the list according to the partitioning for the step above.
    OSX Disk Utility leaves unallocated partitions inbetween which usually are arround 128MB in size.
    Do not try to delete these "blank" partitions.
    2nd partition should be ext4 formatted and mounted "/".
    3rd partition should be ext3 formatted and mounted "/home". (I use ext3 in order to use fuse-ext2 from OSX; ext4 is yet not supported)
    4th partition should be swap (no format and mountpoint required)
    4. The installation process should run through smoothly.
    5. Restart with pressed "Alt"-Key.
    Unfortunately selecting the "Windows" labled Partition (HD-icon) only displayed a black screen with a blinking cursor.
    Reboot into OSX again and install `refind`.
    Download [Binary Zip-File](
    Open a Terminal
    cd Downloads
    cd refind-bin-0.7.4
    6. Restart again. Now a Ubuntu labled '/efi/grubx64.efi' should be shown.
    Select this an start it, now the grub-menu should be displayed.
    Select "Ubuntu".
    Now Ubuntu should boot.

    ## Update Ubuntu and install Wifi driver

    1. Log into ubuntu 13.10 and open a terminal (Ctrl+Alt+t).
    Enter the following commands
    sudo apt-get update
    sudo apt-get upgrade
    This updates all packages
    2. Start (Panel) > (Menu)System Settings > (Icon)Software & Updates (or from terminal `/usr/bin/python3 /usr/bin/software-properties-gtk`)
    Select (Tab)Additional Drivers and install Broadcom 802.11 Linux STA wireless driver from bcmwl-kernel-source
    3. Now reboot again
    Select "Ubuntu"

    ## What works and what does not work

    Feature Support status Notes
    ------------------------ ---------------- -------
    LCD Panel Partly After Suspend only off or on possible
    Suspend, Hibernate OK Suspend works, hibernate not tried out yet
    Shut-down and Reboot OK
    Keyboard functions (Brightness,volume,...) OK
    Keyboard backlight OK
    Touchpad OK
    Wireless OK
    Bluetooth OK
    iSight NO camera is not an usb device
    Sound OK
    Microphone OK sound recoder is broken but recording with audacity works
    External Monitor NO External Monitor cannot be found (see note below)
    Thunderbolt ? To be verified
    SD card slot OK
    HFS+ (OS X disc partition) OK mount read-only ok
    Fan Control OK according to `tlp stat`
    Sensors (temps & fans) OK according to `tlp stat`

    **Issues left:**

    * Backlight on/off after resume:
    Before suspend + resume the behaviour of the backlight pressing F1 or F2 key is linear.
    Checking the register `sys/class/backlight/intel_backlight/brightness` the range from 0 to 2770 can be operated in 21 steps.
    After resume still the full range is triggered with the F1 to F2 keys but here the backlight is turned off for all values less than 2330.
    * iSight HD webcam does not work:
    The camera is not recognized as USB device. The current iSight-Firmware cutter does not help here.
    * External Monitors are not detected properly.
    Sometimes they get detected by accident and "Undetected display" is shown.
    Then only VGA resolutions can be selected but not the external monitor native ones.

    ### Workarround for Backlight issue after resume

    If led-backlight is set to low after resume the screen is to dark to enter the password.
    The following script solves the problem of having to enter the password after resume in darkness.
    But this does not solve the issue of readjusting the brightness
    Paste the below code and copy it into a file nemed `99displayfix`. This copy into the folder `/etc/pm/sleep.d/`
    # installation instructions
    #   sudo cp 99displayfix /etc/pm/sleep.d/
    #   sudo chmod +x /etc/pm/sleep.d/99displayfix
    case "$1" in
    		# set max brightness
    		echo 2550 > /sys/class/backlight/intel_backlight/brightness
    exit $?
    * Alt+F2+Fn (Run Application) not working
    Enabling via (Menu)System Settings > (Item)Keyboard > (Tab)Shortcuts > (Item)Launchers > Key to Show the HUD == Disabled
    sudo apt-get install compizconfig-settings-manager
    # after install start in terminal with
    # (Chaper)General > (Item)Gnome Compatibility > (Item)Run Dialog > Grab Key-Combination "<Alt>F2"
    ### fn-Key change behaviour

    I personally prefer to use fn+Fkeys for the brightness and sound settings but leave the Fkeys for the applications without pressing fn.
    To change this behaviour
    echo options hid_apple fnmode=2 | sudo tee -a /etc/modprobe.d/hid_apple.conf
    sudo update-initramfs -u -k all
    Then reboot.
    For further info on this topic check [here](

    ## Finetuning Powersave

    1. Install powertop
    sudo su
    apt-get install powertop
    Toggle through with "TAB" to Tunables
    Lots of "Bad" values should be displayed.
    2. Install TLP
    For detailed Instructions refer to [](
    sudo su
    add-apt-repository ppa:linrunner/tlp
    apt-get update
    apt-get install tlp tlp-rdw
    3. Edit tlp config `/etc/default/tlp` (only changes are shown)
    Restart tpl with `sudo /etc/init.d/tlp restart`
    Check if settings took effect with `powertop`.
    4. Dim the backlights for screen and keyboard. On startup the values are set to max-level.
    Edit `/etc/rc.local`
    echo 400 > /sys/class/backlight/intel_backlight/brightness
    echo 16 > /sys/class/leds/smc\:\:kbd_backlight/brightness
    sleep 0.2s
    Without the sleep command broken Wifi is the result.
    5. Run `sudo tlp stat`
    /sys/module/i915/parameters/i915_enable_rc6  = -1 (use per-chip default)
    /sys/module/i915/parameters/i915_enable_fbc  = -1 (use per-chip default)
    /sys/module/i915/parameters/lvds_downclock   =  0 (disabled)
    /sys/module/i915/parameters/semaphores       = -1 (use per-chip default)
    Add the following line in `/etc/default/grub`
    GRUB_CMDLINE_LINUX_DEFAULT="pcie_aspm=force i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1 acpi_backlight=vendor"
    Then run `sudo update-grub` and reboot.
    After that:
    /sys/module/i915/parameters/i915_enable_rc6  =  1 (enabled)
    /sys/module/i915/parameters/i915_enable_fbc  =  1 (enabled)
    /sys/module/i915/parameters/lvds_downclock   =  1 (enabled)
    /sys/module/i915/parameters/semaphores       = -1 (use per-chip default)
    **Issues left:**

    * Bluetooth drains quite some battery and cannot be disabled at start.
    `sudo sed -i '$i /usr/sbin/rfkill block bluetooth' /etc/rc.local` does not allow to start bt from "System Settings" later on.
    Still looking for a possibility to disable this from command-line at startup.
    * It would be nice to have the ambient sensor used to trigger the backlights.
    Trying 'lightum' `` results in a crash.

  4. #24
    Join Date
    Feb 2009

    Re: 2013 Macbook Air w/ Haswell & Intel 5000 Graphics

    Did you use my recipe?
    Do you see the orange USB-icon on boot with Alt-key pressed?
    Can you please follow the steps as described one by one? This should do. If not maybe you should change to a different USB-Stick.

  5. #25
    Join Date
    Oct 2013

    Re: 2013 Macbook Air w/ Haswell & Intel 5000 Graphics

    Yep and yep -- I'll give it one more try using the updated directions.

    Got a message at the end of installation saying grub failed to be installed to ./target/ -- will try with a different stick
    Last edited by dougphy; October 18th, 2013 at 10:21 PM.

  6. #26
    Join Date
    Oct 2013

    Re: 2013 Macbook Air w/ Haswell & Intel 5000 Graphics

    Thanks a lot spezimas !
    I follow all your detailed steps and I now have my favorite OS on my macbook air.
    Just a few remarks/questions:

    1. I didn't have any problem with wifi. The Broadcom driver installed itself during installation and everything worked from the first start.

    2. The backlight issue is really anoying. After resume, I have a very bright screen, but I cannot decrease it (I can only hit F1 key 4 times, then the screen is totally black). Is it the same for you ? As you said, low brightness can save lots of battery life, so it would be very great to be able to better adjust brightness after resume.

    3. This could be useful for others : I manage to change the timeout of refind (at startup), by editing the refind.conf file in EFI/refind/ directory (I logged in to mac os to do it).

    4. The link is very useful to remap the keyboard. About that matter, I still don't know if it is possible to swap fn and ctrl key. It seems that we can't do it with the xmodmap as for others keys...

    Anyway, thanks again, I tried mac os for one hour and I was not happy. Now I am !
    Last edited by littlerob2; November 3rd, 2013 at 02:48 PM.

  7. #27
    Join Date
    Oct 2013

    Re: 2013 Macbook Air w/ Haswell & Intel 5000 Graphics

    About the bluetooth issue : the third solution of the following guide works for me :
    (paste '/etc/init.d/bluetooth stop' in the /etc/rc.local file).

  8. #28
    Join Date
    Oct 2013

    Re: 2013 Macbook Air w/ Haswell & Intel 5000 Graphics

    External monitors are properly detected when using latest version of the linux kernel : v3.12-rc7 (kernels can be downloaded frome :

    Finally, it seems that issues left reduce to :
    * backlight issue after resume
    * isight camera undetected

  9. #29
    Join Date
    Feb 2013

    Re: 2013 Macbook Air w/ Haswell & Intel 5000 Graphics

    Thanks littlerob2 for point 3. I was looking for that one.

    However it seems that resetting timeout to 0 disables the wait completely, while choosing a float value (like 0.001) rounds to the nearest int (0 in this case). Currently I have set this value to 1, thus providing the shortest wait possible to boot into ubuntu.

    I wonder if refind has a mechanism for immediately booting to the preferred OS?

  10. #30
    Join Date
    Oct 2013

    Re: 2013 Macbook Air w/ Haswell & Intel 5000 Graphics

    I set this value to 1 too, but I don't know if the immediate boot is possible. Sorry !

Page 3 of 5 FirstFirst 12345 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts