Results 1 to 4 of 4

Thread: exec error when installing wordpress plugin?

  1. #1
    Join Date
    Jan 2013
    Beans
    82

    exec error when installing wordpress plugin?

    Whenever I try to install this real estate wordpress plugin called "Real Estate Website Builder" and I click activate it gives me this error. Also the server is mine and is at my house and i am using a zpanel account i created for my moms real estate that is hosted on my server. My server uses linux ubuntu? How do I fix this error? I really appreciate it.

    Plugin could not be activated because it triggered a fatal error.
    Warning: exec() has been disabled for security reasons in /var/zpanel/hostdata/christina/public_html/omegarealtorsgroup_tk/wp-content/plugins/placester/third-party/mixpanel/mixpanel.php on line 28

  2. #2
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    12,051
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: exec error when installing wordpress plugin?

    Are you running this site with PHP's "safe mode" enabled? If so, you cannot use exec() or any other shell execution command unless the executable resides in the safe_mode_exec_dir and does not include ../ in the path.

    That seems to be the only directive that applies here. Look in /etc/php5/apache2/php.ini to ensure that safe mode is disabled.
    Last edited by SeijiSensei; June 22nd, 2013 at 07:56 PM.
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  3. #3
    Join Date
    Jun 2013
    Beans
    1

    Re: exec error when installing wordpress plugin?

    Quote Originally Posted by SeijiSensei View Post
    Are you running this site with PHP's "safe mode" enabled? If so, you cannot use exec() or any other shell execution command unless the executable resides in the safe_mode_exec_dir and does not include ../ in the path.

    That seems to be the only directive that applies here. Look in /etc/php5/apache2/php.ini to ensure that safe mode is disabled.
    Hey SeijiSensei,

    Safe-Mode has been Disabled And exec has been removed from our Disable_functions list. Here is our following configuration:

    http://www.mindfulhacker.tk/php.ini

  4. #4
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    12,051
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: exec error when installing wordpress plugin?

    What if you just start with a a simple script like this:

    Code:
    <?php
    exec("echo 'Yes, I can run this!'");
    ?>
    Does that fail?

    I don't use zpanel or anything similar, so I can't say how that might interfere.

    Any "../" constructs in the path name of the script being invoked?

    Maybe the problem is that the www-data doesn't have privileges to run whatever is being invoked in exec()? I would think you would get a different error message, but it's worth checking like this:

    Code:
    $sudo su
    [enter your password]
    #su www-data
    $/path/to/your/script
    $exit
    #exit
    Does it run using this method?

    I searched to see if I could find anything about running shell scripts from Wordpress, but didn't get very far.

    Have you checked /var/log/apache2/error.log? Does it help?
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •