Hi, I ran lubuntu for a couple of days then decided to install. Everything appeared to go ok. Then an update request appeared. 335 updates need to be installed. Considered installing in block of 50 or so but new to linux and was concerned about omitting dependancies. About 90% of the updates downloaded then stopped. Looked like it had ran out of space.

I had used the auto install on an 85GB partition but this procedure allocated only 1.75GB swap partition. I thought that the swap should be twice the ram in this case 4GB???

My laptop is a compaq. C60 notebook. 2GHz CPU 2GB ram 160HDD running vista on sda1

Sda1 vista 70GB Sda2 extended 80GB Sda6 ext4 (lubuntu) 78GB Sda5 swap 1.75gb

While watching the updates there appeared to be a lot of "replacement" stuff. I tried sudo apt-get clean to try to get additional space but nothing happened. Used knoppix to try to increase the size of the swap partition but could reduce the size but not increase it.

Pop up again: Upgrade manager wants to run partial update: starts: gets to the same place with the same error : glibc detected lockfile create free invalid next size (fast) 0 glibc detected lockfile -create malloc memory corruption fast 0x09119048

Another message: Software index is broken. it is impossible to install or remove any software Use synaptic or run sudo 'apt-get install -f' to fix this issue. Ran it and got output dpkg was interrupted you must manually run 'dpkg --configure -a' to correct. ran it got command not found.

wireless pci card & wifi usb not working. Hoped the updates & restricted extras would help. Usb wifi works on Ubuntu on my desktop and as soon as I boot into vista it starts working. I have tried about 5/6 distro's live & installed but cannot get the wireless card or usb to work.
Can this be fixed please?? Do I need to re-install manually to increase the swap size?? Are the problems being caused by the small size of the swap partition??

Thanks