Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: enable ssl on squid3

  1. #11
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    12,684
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: enable ssl on squid3

    I use CentOS for servers, and squid compiled correctly for me without much trouble.

    Did you install the "build-essential" package? You should also run "sudo apt-get build-dep squid3" to get the libraries and headers for any dependencies.

    I also found this: http://arfanahmedcheema.blogspot.com...ubuntu-12.html
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  2. #12
    Join Date
    Nov 2010
    Beans
    54

    Re: enable ssl on squid3

    ok
    ill test it and tell you my results

  3. #13
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    12,684
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: enable ssl on squid3

    Squid 3.3.5 will not compile for me on CentOS if I use --enable-ssl-crtd with configure. I get the error described here: http://www.squid-cache.org/mail-arch...1305/0400.html

    I may try again with an earlier minor version like 3.3.4 or 3.3.3.

    Update: I also cannot compile either of those versions.
    Last edited by SeijiSensei; June 20th, 2013 at 11:13 PM.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  4. #14
    Join Date
    Nov 2010
    Beans
    54

    Re: enable ssl on squid3

    squid compile .
    but when i add this as the site said
    http_port 192.168.5.239:3128 transparent ssl-bump generate-host-certificates=on dynamic_cert_mem_cache_size=4MB cert=/usr/share/ssl-cert/myCA.pem
    its want start
    and i cant find it on init.d directory or in services to start or restart it

  5. #15
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    12,684
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: enable ssl on squid3

    I'm impressed that you got it to compile. As I said, 3.3.3-5 have all failed for me. Squid itself compiles fine, but it fails when it gets to the certificate part.

    Did you compile with the "--enable-ssl --enable-ssl-crtd" parameters in configure? It's that last of these that fails for me and for others as I linked to above.

    By default, the daemon will be installed to /usr/local. You'd have to first install the repository version to get the appropriate entries in /etc/init.d, then edit the startup script to use /usr/local/sbin/squid instead of the repository version.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  6. #16
    Join Date
    Nov 2010
    Beans
    54

    Re: enable ssl on squid3

    Quote Originally Posted by SeijiSensei View Post
    I'm impressed that you got it to compile. As I said, 3.3.3-5 have all failed for me. Squid itself compiles fine, but it fails when it gets to the certificate part.

    Did you compile with the "--enable-ssl --enable-ssl-crtd" parameters in configure? It's that last of these that fails for me and for others as I linked to above.

    By default, the daemon will be installed to /usr/local. You'd have to first install the repository version to get the appropriate entries in /etc/init.d, then edit the startup script to use /usr/local/sbin/squid instead of the repository version.


    the compiling done perfect
    but about the start and stop service manual i didnt get it will
    -bash: cd: /usr/local/sbin/squid: No such file or directory

  7. #17
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    12,684
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: enable ssl on squid3

    You really got it to compile with "./configure --enable-ssl --enable-ssl-crtd"? Hmm. I'll have to try again.

    I don't recall any more exactly where make install puts the binaries, but they are definitely under /usr/local by default. It might have created a /usr/local/squid directory. Just browse around in /usr/local; you'll find them.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  8. #18
    Join Date
    Nov 2010
    Beans
    54

    Re: enable ssl on squid3

    configure options: '--prefix=/usr' '--includedir=/usr/include' '--datadir=/usr/share' '--bindir=/usr/sbin' '--libexecdir=/usr/lib/squid' '--localstatedir=/var' '--sysconfdir=/etc/squid3' '--enable-delay-pools' '--enable-ssl' '--enable-ssl-crtd' '--enable-linux-netfilter' '--enable-arp-acl' '--enable-snmp' '--enable-gnuregex' --enable-ltdl-convenience

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •