I know the v10.04 LTS has passed deadline & been declared obsolte - but, I keep checking for updates nonetheless. (Now & then I find one.) However, today something odd happened & I'm not really sure what to make of it.

First, some background: I'm running Ubuntu v10.04 LTS on a Dell Dimension laptop as the primary OS of 3 installed; each in their own partition. The others are Debian "Wheezy" v7.0.0, & Ubuntu v12.04.02 (LTS?) w/ Gnome Classic DE. (I'd consider using one of those as the primary, but they screwed up Gnome's color management so badly, and several of the "upgraded" programs have lost fundamental, vital features. So, those OS's are just extras for toying w/ at whim - much less useful for general work than the Gnome v2 counterparts.)

As I said, I'm still using the Ubuntu v10.04 as the primary OS. When I opened the Update Manager today, I saw entries for a kernel update which ended in ".48". I've found the most efficient way to update kernels is that when I see an update for the primary OS's kernel, I close it down and go check each secondary OS & do updates there. Then, I return to the primary & do the updates. That way, when grub is updated, any & all kernel updates available in the secondaries get registered into the boot selection screen. (There's another way to do it involving doing the primary first, but it's more work; less efficient in time & effort.) So, that was what I did today. I shut it down, booted into each of the secondaries, and did updates in those; then returned to the primary to do the update.

I started the Update Manager, and saw the updates I'd previously seen, including the kernel ending in ".48" update. On general principles, I always click the "Check" button before updating. I did that today, and it obediantly checked. BUT - after checking, it declared that there were no updates available; that my system had been updated "less than an hour ago". I checked in Synaptic, and my system was still showing the kernel ending in ".46" as the most recent version installed. I tried again w/ the Update Manager, and same result showing no updates available and updated less than an hour ago.

I'm not sure what to make of this. Obviously, there's a kernel update ending in ".48" out there somewhere. My system found it before, but now can't. Can anybody explain what's going on with this?

Thanks in advance.