Results 1 to 3 of 3

Thread: Nvidia current : Can't manage to it install correctly

  1. #1
    Join Date
    May 2010

    Nvidia current : Can't manage to it install correctly


    For several days (5 days), I tried everything I saw on the internet to install those drivers. I reinstalled ubuntu or kubuntu at least 20 times both.
    I tried installing nvidia-current with "additional drivers" or with the repository x-swat or manually by downloading them on or with aptitude.
    Every time I end up with a unity broken or on kubuntu a resolution of 640*480 with no opengl or anything working.

    I have hit rock-bottom, please help me !

    I have a laptop Dell-XPS702X (17"), my graphic card is a Nvidia 555m and I use a x64 ubuntu OR kubuntu (either way I'm good).
    I'm installing ubuntu once again, so I can try whatever you think could work.

    I have tried everything with a clean install in here
    I also tried to reinstall lightdm after installing the driver...

    Please help me I don't want to go back to Windows

    Best regards,


  2. #2
    Join Date
    Jun 2009
    SW Forida
    Ubuntu 16.04 Xenial Xerus

    Re: Nvidia current : Can't manage to it install correctly

    Is this a dual video system?

    nVidia Optimus and Ubuntu explained

    Some discussion of limits of new nVidia driver with some Optimus support
    Installing new nVidia driver 319.12 beta
    The problem was caused by another technology by Intel called the Integrated Network Interface Controller (NIC) that was conflicting with my USB controller that prevented my LiveUSB from working

    Often the drivers are the same across Dell models. Not sure if this applies or not.

    Question about Dell's Ubuntu Preloaded XPS 13 Developer Laptop Link to review, Sputnik
    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    May 2010

    Re: Nvidia current : Can't manage to it install correctly

    Thank you

    I see that it is not really optimus supported like I wanted it.
    Actually what I need is a way to run opengl application with my 555m.
    Bumblebee should work (used it before) but it doesn't really work with steam.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts