My Ubuntu "Server" (Desktop install with Samba, moving to server install in December) motherboard crashed and burned last week. Due to the age I decided to upgrade to a newer board/processor/memory. The upgrade went fine, but the system was having issues with many missing/different drivers, and still being new to Linux I just re-installed 13.04 (Fresh install) and figured I needed practice setting things up anyway.

Everything loaded and worked great, until I got to Samba, that is where the saga started. I come here after 2 days of searching forums (here and others) and being unable to solve my problem).

- Trinity: Ubuntu 13.04 "Server" w/Samba on static IP address (
- Roadrunner: My workstation on Windows 7 using router DHCP
- Nelly: Wife's computer on Windows 7 using router DHCP

-Twinpeaksr: My user on all systems, same password on all systems (Also administrator on all systems)
-Mary: My wife's user on all systems, same password on all systems (Not administrator on any systems)
-twinpeaks: group on server that we are both member of, also listed as group that owns the folder being shared

The problem is simple: I have the shares setup and can access them fine with my user on any system. My wife's user can not access the shares, gets the "You do not have permissions" error when trying to access, it worked before I rebuilt the system.

What I tried:
I have tried many things to fix this and look to the intelligence of this forum to help me identify what I am missing.

  1. Have created both Samba (smbpasswd) and Unix user on server
  2. Have created a group (twinpeaks) with both users in it and added to samba valid users
  3. changed ownership of the folder to the "twinpeaks" group that we both are in
  4. Added her user to my group (twinpeaksr)
  5. Changed permissions to full permissions for everyone on the folder (chmod 0775 and 0777 tried)
  6. enabled guest account in Samba
  7. removed password on unix/samba user for her account
  8. added password back on to match windows machine
  9. verified that on the same computer, I can access shares if I login
  10. added her account to the valid users in samba directly
  11. made her an administrator on the server
  12. re-installed Samba
  13. set myself as the guest account

I have also restarted SMBD and NMBD after every change. I have restarted the Windows machine, I have restarted the server. All of this has the same results: I can access the share without issue with my user, she has no access. I am sure the issue is on the server/samba side, but I am running out of options. I have tired a few diagnostic items as well:

  1. tried 'smbclient nellly -NL', could not access the samba client
  2. tried 'smbclient roadrunner - NL' (where I am logged in), get a response that says it is good
  3. Network connections are confirmed good, and I can see the shares at '//trinity/', but when I click on the shares they give the permission error only with her login
  4. verified that she was added to the twinpeaks user group using 'groups mary'

    ; General server settings
    netbios name = trinity
    server string =
    workgroup = workgroup
    announce version = 5.0

    passdb backend = tdbsam
    security = user
    unix password sync = yes
    ; null passwords = true
    username map = /etc/samba/smbusers
    name resolve order = hosts wins bcast

    wins support = yes

    syslog = 1
    syslog only = yes

    path = /media/data500G/Shared
    browseable = yes
    read only = no
    guest ok = yes
    guest account = twinpeaksr
    valid users = @twinpeaks mary twinpeaksr
    create mask = 0644
    directory mask = 0755
I am running out of options, anyone have any other ideas I can try tonight?