Results 1 to 2 of 2

Thread: Gamepad Issue

  1. #1
    Join Date
    Jun 2013

    Gamepad Issue

    I have tried everything I can think of, I mean I am very new to Ubuntu, as in this is only my 2nd day after switching over. I switched my Acer C7 Chromebook over to Ubuntu 12.04. Very happy with the results, except I can't get my USB controller to work. As I said in the title it is a Century Concept Digital USB Gamepad, SKU #234995.I have triedcd /dev/input sudo MAKEDEV js sudo modprobe joydev sudo modprobe ns558 That didn't work. So I tried to install jscalibrator.sudo apt-get install jscalibrator And I gotReading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package jscalibrator Tried thissudo apt-get install joystick Got thisReading package lists... Done Building dependency tree Reading state information... Done The following extra packages will be installed: evtest The following NEW packages will be installed: evtest joystick 0 upgraded, 2 newly installed, 0 to remove and 2 not upgraded. Need to get 61.6 kB of archives. After this operation, 243 kB of additional disk space will be used. Do you want to continue [Y/n]? Y Get:1 raring/universe evtest i386 1:1.30-1 [21.4 kB] Get:2 raring/universe joystick i386 1:1.4.3-1 [40.2 kB] Fetched 61.6 kB in 0s (78.1 kB/s) perl: warning: Setting locale failed. perl: warning: Please check that your locale settings: LANGUAGE = (unset), LC_ALL = (unset), LC_TIME = "en", LC_MONETARY = "en", LC_ADDRESS = "en", LC_TELEPHONE = "en", LC_NAME = "en", LC_MEASUREMENT = "en", LC_IDENTIFICATION = "en", LC_NUMERIC = "en", LC_PAPER = "en", LANG = (unset) are supported and installed on your system. perl: warning: Falling back to the standard locale ("C"). locale: Cannot set LC_ALL to default locale: No such file or directory Selecting previously unselected package evtest. (Reading database ... 127471 files and directories currently installed.) Unpacking evtest (from .../evtest_1%3a1.30-1_i386.deb) ... Selecting previously unselected package joystick. Unpacking joystick (from .../joystick_1%3a1.4.3-1_i386.deb) ... Removing any system startup links for /etc/init.d/joystick ... Processing triggers for man-db ... locale: Cannot set LC_ALL to default locale: No such file or directory Setting up evtest (1:1.30-1) ... Setting up joystick (1:1.4.3-1) ... Then got nothingSo finally I tried one more solution I /dev/input/js0 And I gotcat: /dev/input/js0: No such file or directory All I want to do is use my joypad to play on the emulators! If you can help, I would be so appreciative. Also if you know something that can let me use my pocket moga bluetooth controller as well, that would rule also!Thank you very much!

  2. #2
    Join Date
    Apr 2013

    Re: Gamepad Issue

    OMG to many words, do you have a Xbox 360 conroler? I have two one made by Rock Candy and one by Microsoft. I also have a USB Logitch PS2 PID:w642 controler. I have no idea what controlers you are using as your paragraph is a mess. When it comes to emmulaion on Linux Most emmulators need to be configured manualy. I mean in the game/menu. For example Supertuxkart works with USB controlers, but you have to have it pluged in before you start the game. Supertux 2 suports USB contorlers, but you have to manualy set them in the menu as the defualt layout goes crazy and Supertux does not suport it at all. FreeDink suports it out of the box, and you can set it with Gens/GS how ever just to get Gens/GS you have to use an outdated .deb file and it has not been updated for awhile. VBA also suports them, but you have to what each button is called and type it in, and it might crash afterwords. Mupen64 suports USB, but it is all comand line as of now, big turn off. Frozen Bubble also works affter you configure it too. There are many more games that do work, but the emmulators require a little more knowage about your controlers.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts