Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: WI-FI connected but unable to browse on ubuntu 12.04 lts using hp mini

  1. #11
    Join Date
    Jun 2013
    Beans
    11

    Re: WI-FI connected but unable to browse on ubuntu 12.04 lts using hp mini

    Code:
    $ sudo apt-get install iw
    [sudo] password for bloed: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    iw is already the newest version.
    iw set to manually installed.
    The following package was automatically installed and is no longer required:
      libtrove-java
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 89 not upgraded.
    bloed@bloed-HP-Mini-110-3000:~$ iw reg get
    country 00:
    	(2402 - 2472 @ 40), (3, 20)
    	(2457 - 2482 @ 20), (3, 20), PASSIVE-SCAN, NO-IBSS
    	(2474 - 2494 @ 20), (3, 20), NO-OFDM, PASSIVE-SCAN, NO-IBSS
    	(5170 - 5250 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
    	(5735 - 5835 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
    bloed@bloed-HP-Mini-110-3000:~$ sudo iw reg set NL
    bloed@bloed-HP-Mini-110-3000:~$ iw reg get
    country NL:
    	(2402 - 2482 @ 40), (N/A, 20)
    	(5170 - 5250 @ 40), (N/A, 20), NO-OUTDOOR
    	(5250 - 5330 @ 40), (N/A, 20), NO-OUTDOOR, DFS
    	(5490 - 5710 @ 40), (N/A, 27), DFS
    bloed@bloed-HP-Mini-110-3000:~$ iwlist chan
    lo        no frequency information.
    
    wlan0     14 channels in total; available frequencies :
              Channel 01 : 2.412 GHz
              Channel 02 : 2.417 GHz
              Channel 03 : 2.422 GHz
              Channel 04 : 2.427 GHz
              Channel 05 : 2.432 GHz
              Channel 06 : 2.437 GHz
              Channel 07 : 2.442 GHz
              Channel 08 : 2.447 GHz
              Channel 09 : 2.452 GHz
              Channel 10 : 2.457 GHz
              Channel 11 : 2.462 GHz
              Channel 12 : 2.467 GHz
              Channel 13 : 2.472 GHz
              Channel 14 : 2.484 GHz
    eth0      no frequency information.
    You said to use a fixed channel. I didn't really know where or how to do that, but I did this, hoping it's what you meant:

    Code:
    $ sudo iwconfig wlan0 channel 10
    [sudo] password for bloed: 
    bloed@bloed-HP-Mini-110-3000:~$
    Is it a fixed channel now??
    I don't know if I did it right, but so far the problem is still there. I still cannot ping anything but 127.0.0.1.

  2. #12
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    7,028
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: WI-FI connected but unable to browse on ubuntu 12.04 lts using hp mini

    You need to enter the router interface, check the manual for it.

  3. #13
    Join Date
    Jun 2013
    Beans
    11

    Re: WI-FI connected but unable to browse on ubuntu 12.04 lts using hp mini

    I can't really change anything about the router, because I do not own it. Pretty sure the problem isn't the router though, because it worked fine before, and my cellphone can still use the same network. I checked that when I disabled mobile networking.

  4. #14
    Join Date
    Jun 2013
    Beans
    11

    Re: WI-FI connected but unable to browse on ubuntu 12.04 lts using hp mini

    maybe I should just give up and reinstall ubuntu

  5. #15
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    7,028
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: WI-FI connected but unable to browse on ubuntu 12.04 lts using hp mini

    Try Wicd instead, it can handle mixed mode better than the NM:
    Code:
    sudo apt-get install wicd
    sudo service network-manager stop
    sudo killall wpa_supplicant
    sudo service wicd restart
    Choose wlan0 as interface name and wext as driver in Wicd

  6. #16
    Join Date
    Jun 2013
    Beans
    11

    Re: WI-FI connected but unable to browse on ubuntu 12.04 lts using hp mini

    I already am using wicd...

  7. #17
    Join Date
    Jun 2013
    Beans
    11

    Re: WI-FI connected but unable to browse on ubuntu 12.04 lts using hp mini

    It works again. I don't know how long it will last. The problem has existed for about a week now, and today i am posting from my netbook. Only two things have happened that could have caused it: I turned it off wrong by holding the power switch till it shut down, and when I restarted just now, I switched to Unity 2D. And voilà, web pages. I dare anyone to explain this.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •