Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 31

Thread: No internet connection when setting up Ubuntu 12.04

  1. #21
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    6,726
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: No internet connection when setting up Ubuntu 12.04

    Sorry, I forgot something.

    The current native module needs to be renamed first. Uninstall the dkms driver, rename it and reinstall as described:

    Code:
    sudo dkms remove alx_dkms -v cw20121003 --all
    sudo rm -r /usr/src/alx_dkms-cw20121003
    sudo mv $(modinfo alx | grep filen | awk {'print $2'}) $(modinfo alx | grep filen | awk {'print $2'}).bak
    sudo depmod -a && sudo update-initramfs -u
    Reinstallation:
    Code:
    sudo tar xvf 4987097-alx_dkms-cw20121003.tar.gz -C /usr/src
    sudo dkms add alx_dkms -v cw20121003
    sudo dkms build alx_dkms -v cw20121003
    sudo dkms install alx_dkms -v cw20121003
    sudo depmod -a && sudo update-initramfs -u
    And reloading the driver as described. You better copy/paste these commands

  2. #22
    Join Date
    Feb 2012
    Beans
    15

    Re: No internet connection when setting up Ubuntu 12.04

    Code:
    pro@ubuntu:~$ sudo dkms remove alx_dkms -v cw20121003 --all
    [sudo] password for pro: 
    
    
    -------- Uninstall Beginning --------
    Module:  alx_dkms
    Version: cw20121003
    Kernel:  3.5.0-23-generic (x86_64)
    -------------------------------------
    
    
    Status: Before uninstall, this module version was ACTIVE on this kernel.
    
    
    alx.ko:
     - Uninstallation
       - Deleting from: /lib/modules/3.5.0-23-generic/updates/dkms/
     - Original module
       - No original module was found for this module on this kernel.
       - Use the dkms install command to reinstall any previous module version.
    
    
    depmod.....
    
    
    DKMS: uninstall completed.
    
    
    ------------------------------
    Deleting module version: cw20121003
    completely from the DKMS tree.
    ------------------------------
    Done.
    pro@ubuntu:~$ sudo rm -r /usr/src/alx_dkms-cw20121003
    pro@ubuntu:~$ sudo mv $(modinfo alx | grep filen | awk {'print $2'}) $(modinfo alx | grep filen | awk {'print $2'}).bak
    ERROR: modinfo: could not find module alx
    ERROR: modinfo: could not find module alx
    mv: missing destination file operand after `.bak'
    Try `mv --help' for more information.
    pro@ubuntu:~$ sudo depmod -a && sudo update-initramfs -u
    update-initramfs: Generating /boot/initrd.img-3.5.0-23-generic
    Warning: No support for locale: en_GB.utf8
    pro@ubuntu:~$ 
    Then i did the reinstallation.
    And then:

    Code:
    pro@ubuntu:~$ sudo modprobe -v alx
    [sudo] password for pro: 
    insmod /lib/modules/3.5.0-23-generic/updates/dkms/alx.ko 
    FATAL: Error inserting alx (/lib/modules/3.5.0-23-generic/updates/dkms/alx.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    pro@ubuntu:~$ dmesg | grep alx
    [   20.305732] alx: Unknown symbol compat_dependency_symbol (err 0)
    [   46.898362] alx: Unknown symbol compat_dependency_symbol (err 0)
    [ 2200.450685] alx: Unknown symbol compat_dependency_symbol (err 0)
    [ 2342.118631] alx: Unknown symbol compat_dependency_symbol (err 0)
    pro@ubuntu:~$ lsmod
    Module                  Size  Used by
    radeon                912794  3 
    rfcomm                 47562  0 
    parport_pc             32867  0 
    bnep                   18240  2 
    bluetooth             211812  10 rfcomm,bnep
    ppdev                  17114  0 
    lp                     17800  0 
    parport                46563  3 parport_pc,ppdev,lp
    ttm                    88495  1 radeon
    drm_kms_helper         49259  1 radeon
    drm                   290344  5 radeon,ttm,drm_kms_helper
    coretemp               13642  0 
    kvm                   422160  0 
    ghash_clmulni_intel    13221  0 
    aesni_intel            51134  0 
    cryptd                 20531  2 ghash_clmulni_intel,aesni_intel
    aes_x86_64             17256  1 aesni_intel
    i2c_algo_bit           13565  1 radeon
    video                  19598  0 
    snd_hda_codec_hdmi     32476  1 
    snd_hda_codec_idt      70774  1 
    snd_seq_midi           13325  0 
    snd_hda_intel          34117  5 
    snd_hda_codec         135141  3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
    snd_hwdep              17765  1 snd_hda_codec
    snd_pcm                97523  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
    microcode              23030  0 
    snd_rawmidi            30750  1 snd_seq_midi
    snd_seq_midi_event     14900  1 snd_seq_midi
    snd_seq                61931  2 snd_seq_midi,snd_seq_midi_event
    snd_timer              29990  2 snd_pcm,snd_seq
    snd_seq_device         14498  3 snd_seq_midi,snd_rawmidi,snd_seq
    psmouse               102075  0 
    serio_raw              13216  0 
    snd                    83674  20 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    joydev                 17694  0 
    lpc_ich                17145  0 
    mac_hid                13254  0 
    soundcore              15092  1 snd
    snd_page_alloc         18573  2 snd_hda_intel,snd_pcm
    mei                    41410  0 
    hid_generic            12541  0 
    usbhid                 47259  0 
    hid                   100815  2 hid_generic,usbhid
    usb_storage            49288  1 
    uas                    18073  0 
    pro@ubuntu:~$ ifconfig -a
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:624 errors:0 dropped:0 overruns:0 frame:0
              TX packets:624 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:51168 (51.1 KB)  TX bytes:51168 (51.1 KB)
    
    
    pro@ubuntu:~$ 

  3. #23
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    6,726
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: No internet connection when setting up Ubuntu 12.04

    Please reboot and check:
    Code:
    lsmod | grep alx
    ifconfig -a
    dmesg | grep alx
    modinfo alx | grep filen
    locate alx.ko | grep lib
    locate alx.bak | grep lib

  4. #24
    Join Date
    Feb 2012
    Beans
    15

    Re: No internet connection when setting up Ubuntu 12.04

    Code:
    pro@ubuntu:~$ lsmod | grep alx
    pro@ubuntu:~$
    Code:
    pro@ubuntu:~$ ifconfig -a
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:16 errors:0 dropped:0 overruns:0 frame:0
              TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:1312 (1.3 KB)  TX bytes:1312 (1.3 KB)
    
    
    pro@ubuntu:~$
    Code:
    pro@ubuntu:~$ dmesg | grep alx
    [   19.336945] alx: Unknown symbol compat_dependency_symbol (err 0)
    pro@ubuntu:~$
    Code:
    pro@ubuntu:~$ modinfo alx | grep filen
    filename:       /lib/modules/3.5.0-23-generic/updates/dkms/alx.ko
    pro@ubuntu:~$
    Code:
    pro@ubuntu:~$ locate alx.ko | grep lib
    pro@ubuntu:~$
    Code:
    pro@ubuntu:~$ locate alx.bak | grep lib
    pro@ubuntu:~$

  5. #25
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    6,726
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: No internet connection when setting up Ubuntu 12.04

    Code:
    pro@ubuntu:~$ modinfo alx | grep filen
    filename:       /lib/modules/3.5.0-23-generic/updates/dkms/alx.ko
    pro@ubuntu:~$
    
    pro@ubuntu:~$ locate alx.ko | grep lib
    pro@ubuntu:~$
    Now, this is kinda strange. Please uninstall it again as described, reboot, and try this version:

    http://media.cdn.ubuntu-de.org/forum...lx_only.tar.gz


    Save it in "Downloads" and install it via:
    Code:
    cd ~/Downloads/
    tar xvf 4981437-compat-wireless-2012-10-03-pc_alx_only.tar.gz
    cd compat-wireless-2012-10-03-pc_alx_only
    ./scripts/driver-select alx
    make
    sudo make install
    sudo depmod -a
    sudo modprobe -v alx
    sudo modprobe -v alx

  6. #26
    Join Date
    Feb 2012
    Beans
    15

    Re: No internet connection when setting up Ubuntu 12.04

    I did what you say and suddenly: "Wired connection 1 - Connection established", yay!

    Big thanks to you!

    But one last question.
    I installed Ubuntu besides Win 7, just to have an option if I wouldn't get an internet connection under Ubuntu...
    But I want to delete Win 7 from my hard drive forever.
    So what files should I backup to my external hard drive to get an internet connection as soon as possible when
    I re-installed Ubuntu?

  7. #27
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    6,726
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: No internet connection when setting up Ubuntu 12.04

    1) Thats Ok, but: after a kernel upgrade you need to compile again, so do not remove the respective folder:
    Code:
    cd ~/Downloads/compat-wireless-2012-10-03-pc_alx_only
    ./scripts/driver-select restore
    ./scripts/driver-select alx
    make clean
    make
    sudo make install
    sudo depmod -a
    sudo modprobe -v alx
    2) You dont need to copy sth. back. Use the Live-CD and wipe the windows partitions with gparted

    https://help.ubuntu.com/community/GParted

    Did you install the bootloader into the master boot record (MBR)?

  8. #28
    Join Date
    Feb 2012
    Beans
    15

    Re: No internet connection when setting up Ubuntu 12.04

    Ok i did step 1) .

    Well, so how do I use gparted in this situation?
    I installed Ubuntu via the wubi.exe in Win 7...
    So Ubuntu is part of my Win 7 C:/ partition?
    When I use gparted via the Live-CD I can only see one big partition, nothing
    like 1 Win 7 partition and 1 Ubuntu partition...

    You know what I mean? ^^

    Did you install the bootloader into the master boot record (MBR)?
    No, i didn't install anything like that.

  9. #29
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    6,726
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: No internet connection when setting up Ubuntu 12.04

    You need the deb-files from #6 and the driver from #25

  10. #30
    Join Date
    Feb 2012
    Beans
    15

    Re: No internet connection when setting up Ubuntu 12.04

    Ok.
    I successfully installed Ubuntu to my hard drive and removed Windows forever.
    I got full connection to the internet.
    All is working great, my problems were solved!

    Thank you so much for your help, herzlichen Dank auch!

Page 3 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •